7

On Lubuntu 16.04, System Tools > Printers - there is no option to add a network printer.

Is there a way to do that? thanks


Edit: Based on sancho.s answer, this works for me (with a HP printer)

1) sudo apt-get install cups

2) System tools > Printers

3) On Printers - localhost : the Add dropdown button now works, choose Printer

4) On Select Device - choose AppSocket/HP JetDirect

5) On Location of the network printer - enter "Host" IP address (port number default to 9100)

6) Name the network printer and done

Notes it appears that these two commands are necessary before the printer shows up on application (such as kate):

# systemctl status cups.service

# systemctl enable cups.service

(https://forums.opensuse.org/showthread.php/484492-Cups-http-localhost-631-admin-gone-missing)

(the final command for some reason requires entering the admin password several times)

After all these, printing works ok on Lubuntu (a bit of a hassle).

  • Can you reinstall the printer configuration GUI ? sudo apt-get install --reinstall system-config-printer-common system-config-printer-gnome. – Liso Oct 13 '17 at 2:38
  • @Liso thanks. After reinstall using your command on Lubuntu, I went to System Tools > Printers - and again it only shows localhost. The Add menu was greyed out. The Server > Connect... only allows to connect to localhost, could not enter any IP address as does the normal Ubuntu. – artm Oct 13 '17 at 4:01
  • Could you post a screenshot of what you get with sudo system-config-printer? You should be able to Add -> Printer -> Network printer. – sancho.s ReinstateMonicaCellio Oct 13 '17 at 7:33
  • @artm - what model (brand) is your network-printer ? – dschinn1001 Oct 13 '17 at 20:07
5
+50

You probably have to install CUPS to be able to install printers; since 16.04 it is not part of the basic Lubuntu anymore. This is apparently a reason for quite a few people not being able to add printers in Lubuntu 16.04. The command is likely

sudo apt-get install libcups2:i386 libcupsfilters1:i386 libcupsimage2:i386 

instead of the typical

sudo apt-get install cups

You should try, I found contradicting info on this point.

Once you have CUPS (and you later mentioned you have it), configure the printer from CUPS, e.g., going to http://localhost:631/ -> Administration -> Add printer. Note: you have to: 1) be root, 2) be in the list of sudoers (this is what I use now), or 3) disable password protection for users in CUPS.

enter image description here

This is one of the possible methods listed here to manage printers. The link contains other possibly useful info (the source of your problem is not clear at this point).

Note that the Help menu in the web interface for CUPS contains a significant amount of information.

| improve this answer | |
  • thanks. I had no problems with Ubuntu, but it looks like this problem is specific to Lubuntu 16.04. The cups has already been installed and started, yet there was no option to add network printer – artm Oct 13 '17 at 2:24
  • @artm - Even if the referenced post is from askubuntu, it refers to Lubuntu 16.04, as you have. It appears that CUPS is not installed by default, and that is a reason for many people not being able to add printers. You have CUPS, so I infer that you installed it on your own. Is that correct? Please see my updated answer. – sancho.s ReinstateMonicaCellio Oct 13 '17 at 7:21
  • 1
    thanks for the update, I'll check on Monday and keep you posted. I find Lubuntu very nice and clean - much better than Ubuntu unity (in my opinion). So I actually installed Lubuntu on 3 machines, including my new laptop running pretty decent 7700hq. The network printing thing on Lubuntu is pretty much a 1st complain. Hopefully I can fix it, and can stick with Lubuntu for some long time ;) – artm Oct 13 '17 at 11:44
  • @artm - On one hand, you seemed to already have CUPS, and still Add was greyed out. But then in the procedure you list you mention installing CUPS, and then Add became available. This puzzled me somewhat... – sancho.s ReinstateMonicaCellio Oct 16 '17 at 12:25
  • I thought cups was already available because this sudo apt-get install libcups2:i386 libcupsfilters1:i386 libcupsimage2:i386 appeared to do nothing as if everything installed. But today I tried sudo apt-get install cups then it seems to install. – artm Oct 16 '17 at 12:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.