6

After installing Ubuntu 11.10 on a new PC I have sound working and I have the Login Sound working but I don't get any other alert / notification sounds. e.g. If a question box pops up - there's no sound.

I've tried some other suggestions like copying all the sound files to the /usr/share/sounds folder but this hasn't helped.

Any ideas will be greatly received.

2
  • Did you take a look at this question - re-enable "popping" sounds Commented Jan 16, 2012 at 18:39
  • Yes I've done all of those things and they don't make any difference to my alert sounds not working. Thanks for the advice.
    – Peter
    Commented Jan 17, 2012 at 9:59

3 Answers 3

2

This issue has been resolved in Ubuntu 12.04 by enabling system sounds using Ubuntu Tweak - Ubuntu Tweak

This worked for me in Ubuntu 12.04.

1
  • It is a shame that such settings require the additional installation of a tweek-tool; these things ought to be achievable here. Commented Jun 8, 2015 at 15:54
0

I hope my answer isn't too simple, but did you check the volume control for alerts?

This has gotten me before... in the system settings, under "Sound", there is, in addition to the "Output volume" at the top, a slider for "Alert volume" in the Sound Effects tab.

I've been bit twice when this was set to minimum, and a lot of sounds didn't seem to work.

6
  • Hi, I've checked this and yes the volume is NOT at zero. And when I click on the Alert volume slider I hear a POP sound. So I know it should be working.
    – Peter
    Commented Jan 17, 2012 at 9:57
  • Sorry, but I thought it was worth mentioning. So, it's only alerts, not regular audio and video? If so, the only other thing I can think of is that the sound files are either bad or not playable. Can you play them with an audio player? Or, if not, can you specify a known-good sound for the alert? Commented Jan 18, 2012 at 2:37
  • Hi,I've been able to play all of the sound files which are in the /usr/share/sounds folder and all sub-folders too. So that should mean that the files are fine.
    – Peter
    Commented Jan 18, 2012 at 11:39
  • Just another point of interest, The files in the sounds/freedesktop folder have the extension .oga where as the files in the /sounds/ubuntu/ folder are .ogg. Do you know if this has any impact? Also, which sound file is the system set to use as a default?
    – Peter
    Commented Jan 18, 2012 at 11:45
  • I haven't paid a lot of attention to the details, probably because there doesn't appear to be much ability to configure them. So, I looked closer so I could at least tell you what my system is like. The alerts that can be selected in the sounds setting are in gnome/default/alerts - there are 4 (bark, drip, etc). Do these work in the sounds dialog when you click on them? They should make a sound simply by highlighting. I'm not sure if my dialogs make a sound - they might not. I do know Skype makes lots of sounds, and these are the ones I found to be very low volume initially. Commented Jan 18, 2012 at 16:44
0

I have found the answer to this problem, at least for my system. It is not a sound problem, it is a Compiz problem.

I went into the system settings => universal access => hearing tab, and turned on the visual alerts. Nothing happened when I pressed the test button. So, I thought that the event was not being fired. I also tried typing echo -e "\a" in gnome terminal, and no sound was emitted.

I then ran metacity --replace and the sounds started working in all places, as expected. Returning to Compiz (compiz --replace) made them stop.

EDIT: I guess I was in the gnome compatibility mode when I did this test, and did not realize it's harder in Unity, because the window manager doesn't appear to run and Alt-F2 doesn't work. However, I tried it in Unity, and was able to bring up the Terminal using Alt-Ctrl-T, then ran "Compiz --replace&" from that to get back to Unity.

Sorry to anyone who may have suffered due to my post.

4
  • So it's nothing that I've done wrong - and basically nothing I can do to resolve the problem! I just have to wait for someone to fix ubuntu 11.10 or hopefully 12.04?
    – Peter
    Commented Jan 19, 2012 at 22:09
  • I guess so, unless you want to switch to metacity. It can be done without logging out, by the way. I filed a bug report in the Compiz bugzilla (bug report #70). Commented Jan 19, 2012 at 22:29
  • 1
    I tried switching to metacity and I lost all function of my desktop - no unity bar - no menus I had to turn off my computer just to get back to a usable system. Very strange. But thank you very much for your help. I can stop thinking about it now and just wait for a fix in the future.
    – Peter
    Commented Jan 20, 2012 at 23:06
  • Oops! Sorry to have caused you problems, but I'm glad it came back. I've had that happen at various other times, often when clicking on one setting in CCSM or something similar. So, you weren't able to run any commands at all, like with Alt-F2? Commented Jan 21, 2012 at 0:28

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .