0

I have Ubuntu GNOME 16.04 LTS installed on a Dell XPS 13, and I want to disable the touchpad.

The Dell XPS 13 does not have a key combination for enabling and disabling the touchpad. Unfortunately, also the GNOME settings for mouse and touchpad do not provide any means to enable and disable the touchpad. The accepted answer to another question says that I need to install xserver-xorg-input-libinput. However, sudo apt-get install xserver-xorg-input-libinput fails with the following error message:

The following packages have unmet dependencies:
 xserver-xorg-input-libinput : Depends: xorg-input-abi-22
                               Depends: xserver-xorg-core (>= 2:1.17.99.902)
E: Unable to correct problems, you have held broken packages.

Apparently, xorg-input-abi-22 does not exist in the package archives.

I am able to enable and disable the touchpad with synclient, but I would like to have an approach that keeps the state of the touchpad among reboots.

  • Umm... does the touchpad toggle button in Settings > Mouse & Touchpad not work? – pomsky Sep 27 '17 at 22:05
  • There is no such button. The only things that are there are the general settings (choice of primary key, double click speed) and the mouse settings (pointer speed). – Wolfgang Jeltsch Sep 27 '17 at 22:45
  • I see. I have one such button in 17.04 GNOME and it works (haven't checked whether it remembers the state after reboot though). But I don't remember if I installed any extra package(s) for that. – pomsky Sep 27 '17 at 22:55
  • If you used the 16.04.2 or 16.04.3 image the you're using the hwe xserver. If so then you'd need to stick with that. In this case you'd want xserver-xorg-input-libinput-hwe-16.04 & after installing that, (if not already installed), you'd remove the xserver-xorg-input-synaptics-hwe-16.04 package. Then reboot. – doug Sep 28 '17 at 4:07
  • I did what you suggested. The mouse settings (pointer speed) were replaced by touchpad settings (pointer speed, press to click, scrolling with two fingers, natural scrolling). No possibility to disable the touchpad though. – Wolfgang Jeltsch Sep 28 '17 at 22:42
0

for disable and enable touchpad, first see id of your touchpad using this command :

xinput list

this exmaple for the output , and look ad the id of your touchpad : enter image description here

then , you can use this command to show all available command :

xinput list-props "your-touchpad-id"

this output for my touchpad

enter image description here

and finally , you can disable your touchpad using this command :

xinput set-prop "your-touchpad-id" "Device Enabled" 0

and this command if you want enable the touchpad :

xinput set-prop "your-touchpad-id" "Device Enabled" 1 

It's work for me, hope this will help you.

EDIT 1:

to make it disable on reboot or startup open startup application on your unity dash, then click add, new pop up window will appear, then fill like this :

Nane : disable touchpad (or whatever you want)

command : xinput set-prop "your-touchpad-id" "Device Enabled" 0

comment : this command to disable touchpad at startup (or whatever you want)

take a look at this picture : enter image description here

hope this will work for you too..

  • With this method, the touchpad does not stay disabled among reboots, does it? – Wolfgang Jeltsch Sep 29 '17 at 0:49
  • take look at my answer, I have been updated my answer, hope it will help you – Deki Akbar Sep 29 '17 at 14:24
  • Hmm, I would like the system to remember the state among reboots; so if the touchpad was disabled before the reboot, it should be disabled afterwards, but if it was enabled before, it should be enabled afterwards. I thought there must be a dconf setting for this, but so far, I could not find such a setting. Note that I use GNOME, not Unity. – Wolfgang Jeltsch Sep 29 '17 at 17:58
-1

Open terminal (or menu) and type: dconf-editor. When it opens you go to: org > gnome > desktop > touchpad > tap-to-click, and check the box to the right of the previous menu. Now you can use the click with the touchpad.

  • Please write your answer in English. – stumblebee Mar 15 '18 at 1:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.