Something kinda weird happened to me today.

I've been using Ubuntu for month on my computer without any issue but today I decided to install Windows 7 on dual boot so that my GF can use Photoshop... Of course I had issue installing windows so I had to hard reboot it.

After doing this, Ubuntu could not activate my network card and failed to connect to my network(rebooting didn't do anything). I had to go back to windows and restart it "safely" in order to fix it.

Now my computer connects back to my network but internet is really slow. DNS resolution takes a long time. Speedtest.net shows a unstable link.

ifconfig shows dropped RX packets.

pate@pepette-i7:~$ ifconfig eth0 eth0      Link encap:Ethernet  HWaddr 50:e5:49:3a:64:b1  
          inet addr:  Bcast:  Mask:
          inet6 addr: fe80::52e5:49ff:fe3a:64b1/64 Scope:Link
          RX packets:2261 errors:0 dropped:2261 overruns:0 frame:2261
          TX packets:17701 errors:0 dropped:23 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:2204486 (2.2 MB)  TX bytes:1122744 (1.1 MB)
          Interrupt:42 Base address:0xe000

Using a netbook on the same networks works fine so it's not the router. And going back to windows works fine too so It's hardware related.

I tried to switch to google's DNS, /etc/init.d/networking restart, ifconfig eth0 down, ifconfig eth0 up.

After some testing, local network is intermittent too. If I connect from my laptop to the computer it works but then freeze and I can't type anything in the ssh client.

Don't know what to do now :(

Thanks for reading.

  • Hmm. I'll chew on this one. You've tried all of the things I'd have suggested so far... – Mat Nadrofsky Jan 16 '12 at 16:54
  • Some solutions posted here may be of some help - there are also similar linked questions with more possible solutions. It appears this is a common ailment of a dual boot system. – rlemon Jan 16 '12 at 17:15

I wonder if this is driver related somehow. As in, if Windows 7 somehow adjusted a setting on the firmware of your card by installing one of it's drivers. Now, the standard Ubuntu driver is no longer working correctly as a result of this setting change. This is just a theory, but have you tried downloading or installing any "restricted" manufacturer specific drivers within Ubuntu for your particular network card?

To test this theory, if you can't find Linux specific drivers from the manufacturer, then have a look at trying a configuration using ndiswrapper, specifically ndisgtk. This would theoretically let you use the same "driver" as Windows is using and thus may alleviate your issue.

To install ndisgtk, in a terminal just do a:

sudo apt-get install ndisgtk

Best of luck!

Update: Seems to be related to your chipset/hardware as listed in the comments below. I did a Google search on "ndisgtk RTL8111" and sifted through to find this link, where someone solved an issue with this same chipset using Windows drivers and ndisgtk. Hope this helps.

  • Apparently this seems to be related to bugs.launchpad.net/ubuntu/+source/linux/+bug/853671 and As you say it could have been related to win7 drivers installation but now It sounds bad I dont really know how to patch things and such – Paté Jan 16 '12 at 17:09
  • Gotcha. I'd try the ndisgtk, grab the windows drivers and see if that works? You've got nothing to loose really at this point since it's already not working right. – Mat Nadrofsky Jan 16 '12 at 17:11
  • Try following through this. Similar network hardware to yours, and they had to track it down from the windows side: ultimateeditionoz.com/forum/viewtopic.php?t=3515 – Mat Nadrofsky Jan 16 '12 at 17:15
  • This article might be even better: answers.launchpad.net/ubuntu/+question/181614 – Mat Nadrofsky Jan 16 '12 at 17:18
  • Thanks for your help. After going thru all your links I found a native linux solution. Turns out ubuntu is using r8169 instead of r8168 and that cause an issue for some reason. I still dunno why windows changed it but now it's back to normal. Once again thanks for your suggestions. – Paté Jan 16 '12 at 17:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.