1

I believe this occurred after I tried to change the name of my computer since it was a default and had a bunch of numbers after it.

After changing it, I started to experience weird things with my sudo command, such as my password failing multiple times. A reboot ended up fixing that.

Now I am trying to run my bitcoin-core using bitcoin-qt in the terminal.

It gives me this error:

bitcoin-qt: symbol lookup error: bitcoin-qt: undefined symbol: _ZN12QApplication10commitDataER15QSessionManager

I've tried to uninstall using --purge and reinstall. I've deleted the folder in /usr/bin/bitcoin-qt and tried running it from that folder itself but still wouldn't work.

I'm not sure if there is a config file somewhere else that it uses but I've tried just about everything short of a complete OS reinstallation and nothing will work.

I did change my hostname in /etc/hosts and /etc/hostname and even tried to change it back to what it originally was which was like "xxx-GL551JK" but my bitcoin core refuses to open.

I've tried running just the program itself too from the Search menu and that doesn't work either.

Edit 1: I just reinstalled a fresh copy of Ubuntu and the same error popped up. I literally had this thing running yesterday. I'm already pretty tired of Ubuntu. Almost nothing works out of box.

Edit 2: I just did a second reinstall while overwriting the entire SSD and installed it just the way I did the first time and it's all working again.

Edit 3: I've reinstalled this system I don't know how many times. Every time I reset my computer after downloading the Core, it gives me this lookup error. Literally have reinstalled 4 times and every time it occurs after restarting my computer. I've closed the application and even sudo killall bitcoin-qt every time I tried to log off and then it inevitably gives me this same symbol lookup error. I've even tried 2 different versions of Ubuntu.

2
  • Did you bother to find out how changing a hostname would affect your bitcoin app before doing so, and how long have you been using Ubuntu? – George Udosen Sep 27 '17 at 5:47
  • Why should changing my name on a computer that gives me a UI to change my name affect anything? It's like offering a button to blow up your system in a folder on the Desktop. – cchoe1 Sep 29 '17 at 16:41
0

I found the solution:

I'm on a 64 bit installation of Ubuntu 16.04.

I went to /usr/local/lib and found all my QtCore/QtGui/QtNetwork files there. I moved them all to /usr/.

Now I can run Bitcoin-qt again fine.

I have no idea why it breaks or why it cannot seem to run after the initial boot up or why this fixes it but it seems to work.

Note: There are many libQtCore/Gui/Network files for many different programs but it seems Bitcoin-qt uses the ones in /usr/local/lib and it breaks for some reason whenever you restart the computer. Moving them fixed it for me but only moving the ones in /usr/local/lib and all of them.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.