1

I have dual boot with Windows 10 and Ubuntu, and when I open the Files application, I can see the Windows partition in "+ Other Locations" (99Gb Volume), but I cannot see it under /media/user/:

First image

And then when I click on the Windows partition (99Gb Volume), it shows under /media/user/:

Second image

First question: Is there a way to mount it via terminal? I have a script that backs up Windows files into my external HDD, but I'd like to mount it via script, so I don't need to first open it via Files application.

Second question: Is there a way to rename this Windows partition (9866C54866C52838) to a friendlier name so I can use it in the script more easily?

  • 3
    You can only mount a partition once, use label. Best with Linux not to use spaces, use CamelCase, under_score, or justonename for everything. Your label has a space so then you have to use quotes or escape characters to work around the space. Also have you turned off fast start up in Windows 10. That keeps all NTFS partitions hibernated & the Linux NTFS driver will not auto mount and manual mount will be read only. askubuntu.com/questions/843153/… & askubuntu.com/questions/145902/… – oldfred Sep 26 '17 at 22:54
2

Thanks @oldfred for sending me the links, I could add it to my script and now it works:

# Mount Windows Partition
mount -t ntfs-3g -o ro /dev/sda2 /media/wh9whi9d7/windows

# Backup
rsync ...

# Unmount Windows
umount /dev/sda2

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.