I remember in the past I had some trash that I deleted that needed root privileges so I opened nautalius by running sudo nautalius I then clicked on the trash folder and selected empty. It worked, however I did it this time by using terminal commands. I ran the following commands from a ask ubuntu question with the following:

Where I got the anwser

You can delete the content of the folder from the terminal:
sudo rm -fr ~/.Trash/*
Hardy Heron:
sudo rm -fr ~/.local/share/Trash/files/*

These commands worked as it did clean my trash out with root privileges.

I then tried using the same command that I used the first time:

sudo nautalius

I click "trash" and for some reason I get an error

I do not remember getting this error the last time I did this, I suspect I may have done something wrong.

Screenshot of error

Did one of the commands I ran do something to the folder?

Did I do something wrong? What does this error mean?

Edit: I forgot to mention that I can select the trash directory just fine without root access.


  • I think nautilus naturally didn't find trash folder. What you see in it is a broken shortcut to a item you purged before. – Redbob Sep 26 '17 at 16:13
  • Thanks for the feedback! Is there can way I can fix this? – user739571 Sep 26 '17 at 16:14
  • I found this link but nothing on here seems to help. askubuntu.com/questions/490025/… It said something about going to ~/.local/share/trash, and this directory works with root access. I'm guessing that I need to restore the shortcut, but I have no idea on how to do this. – user739571 Sep 26 '17 at 16:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy