4

Basic System specs:

  • Samsung SSD 500GB
  • CPU: Intel i5-7500
  • RAM: 16GB
  • GPU: NVIDIA GeForce GTX1080
  • Currently configured to Dual Boot with Windows 10 64bit, but Windows boots without any havoc.

Issue:

Ubuntu 16.04 hangs in boot splash screen indefinitely, but after trying to fix it, now it successfully boots into shell mode. In addition, even pressing on ESC when it hangs doesn't display any logs.

So I couldn't see the boot log other than SSHing into my desktop, and open /var/log/boot.log

Here's what I got, while it was hanging:

[  OK  ] Started Network Manager Wait Online.
[  OK  ] Reached target Network is Online.
[  OK  ] Started Daily apt download activities.
[  OK  ] Started Daily apt upgrade and clean activities.
[  OK  ] Reached target Timers.
[  OK  ] Started crash report submission daemon.
         Starting /etc/rc.local Compatibility...
[  OK  ] Started /etc/rc.local Compatibility.
         Starting Terminate Plymouth Boot Screen...
         Starting Hold until boot process finishes up...

I also tried dmesg | less after numerous googling to view the boot logs, and encountered into this at the end of it:

[    2.604476] random: crng init done
[    2.631750] IPv6: ADDRCONF(NETDEV_UP): enp2s0: link is not ready
[    2.651404] r8169 0000:02:00.0 enp2s0: link down
[    2.651432] r8169 0000:02:00.0 enp2s0: link down
[    2.651488] IPv6: ADDRCONF(NETDEV_UP): enp2s0: link is not ready
[    2.691320] NVRM: Your system is not currently configured to drive a VGA console
               on the primary VGA device. The NVIDIA Linux graphics driver
               requires the use of a text-mode VGA console. Use of other console
               drivers including, but not limited to, vesafb, may result in
               corruption and stability problems, and is not supported.
[    2.861207] input: HDA NVidia HDMI/DP,pcm=3 as /devices/pci0000:00/0000:00:01.0/0000:01:00.1/sound/card1/input14
[    2.861248] input: HDA NVidia HDMI/DP,pcm=7 as /devices/pci0000:00/0000:00:01.0/0000:01:00.1/sound/card1/input15
[    2.861281] input: HDA NVidia HDMI/DP,pcm=8 as /devices/pci0000:00/0000:00:01.0/0000:01:00.1/sound/card1/input16
[    2.861312] input: HDA NVidia HDMI/DP,pcm=9 as /devices/pci0000:00/0000:00:01.0/0000:01:00.1/sound/card1/input17
[    5.426350] r8169 0000:02:00.0 enp2s0: link up
[    5.426356] IPv6: ADDRCONF(NETDEV_CHANGE): enp2s0: link becomes ready

It seems like there is an issue with the NVIDIA card as I initially thought.

What I have done to fix this problem:

  1. Update GRUB
    • Went to recovery mode and open terminal
    • Changed the boot mode from quiet splash to acpi=force to force the boot into shell, now I rolled that back.
    • cat /etc/X11/default-display-manager reveals lightdm as the default.
  2. Update Intel video card driver
  3. I tried using boot-repair to fix grub issues, and the results are as such on pastebin: http://paste.ubuntu.com/25620967/

What I might have done to cause this problem:

  1. sudo service lightdm stop

    • In an effort to attempt controlling the GPU fan headlessly.
    • But I ran sudo service lightdm restart
    • Now I believe lightdm doesn't start up at boot.
    • Here is the link I followed to control GPU fan remotely
  2. sudo service lightdm restart

    • I tried restarting lightdm, and it does give me some positive output which is the login screen, but I can't do anything here as it is still frozen.
    • I try typing stuff on the keyboard but nothing shows up.

Can someone please help me figure this out??? I am really clueless and about to cry....

  • I erased the nvidia-384 driver. Error persisted, but the situation did change. At this point I will simply give up and reinstall Ubuntu, and hope not to run into the same situation again. – Jay Shin Sep 26 '17 at 15:21
  • 1
    short of doing battle installing Nvidia drivers directly from their download page you can install Nvidia from Settings -> Software & Updates -> Additional Drivers ... and reboot ... as a veteran of many such black screens while mucking about with Nvidia I know your pain ... this new method may give you the driver version you need – Scott Stensland Sep 26 '17 at 15:31
2

So as I commented above, I reinstalled Ubuntu 16.04, and the nvidia-384 driver to test out my theory on the cause of this havoc.

I strictly followed this link to control GPU fan remotely.

It works like a charm, but after that, I ran into the same rebooting error.

However, this time, I was able to simply call sudo service lightdm restart from my ssh connection, and I was able to successfully login.

So right now, I changed quiet splash in sudo vim /etc/default/grub to acpi=force so that I will boot into shell directly with no display.

This is really annoying, and I really would appreciate somebody if he/she could propose a working solution to this mess.

UPDATE

I was able to fix the issue in the end.

After having a clean install of Ubuntu, instead of following the instructions in the above link, I did such:

sudo env DISPLAY=:0 nvidia-settings -a [gpu:0]/GPUFanControlState=1 -a [fan-0]/GPUTargetFanSpeed=100

  • 1
    I had the same experience, after following the same link you mentioned to control GPU fan and I fixed it without reinstalling by: boot recovery mode, enable system write mode, and reset the boot target to graphical.target by using this informations as a guide: systutorials.com/239880/change-systemd-boot-target-linux – Mihai MATEI Jan 21 '18 at 14:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.