15

Gnome-software, which is one of the top memory consumers, is being loaded at startup and thus decreasing boot time. enter image description here

I rarely use gnome-software, and on most boot-ups it is useless. However there is not an entry at start-up apps, not even after showing hidden startup apps (https://help.ubuntu.com/community/ShowHiddenStartupApplications). Also, I haven't found any gnome-software-related process from systemd-analyze to disable it with systemctl.

12

Go to /etc/xdg/autostart/ and remove the NoDisplay=true line in gnome-software-service.desktop file (or change true to false). Then GNOME Software should appear in Startup Applications list. You can disable it from there.


If GNOME Software still doesn't appear in Startup Applications list following the suggestion above, first copy of the /etc/xdg/autostart/gnome-software-service.desktop file to ~/.config/autostart and then append an

X-GNOME-Autostart-enabled=false

line to the copied file.

|improve this answer|||||
  • I have followed instructions from help.ubuntu.com/community/ShowHiddenStartupApplications , so it has NoDisplay=false, yet it doesn't show up. – TheLinuxGK Sep 25 '17 at 18:58
  • @TheLinuxGK Just to make sure, after running the command from the guide, did you check whether NoDisplay= correctly got changed to false in particular in gnome-software-service.desktop? Funny things can happen! If it doesn't please try changing it manually using nano or something else and see if GNOME Software appears in Startup Applications list. – pomsky Oct 16 '17 at 10:18
  • I just checked, it is NoDisplay=false – TheLinuxGK Oct 18 '17 at 10:32
  • 1
    ibin.co/3eDKcUDKPlxI.png – TheLinuxGK Oct 18 '17 at 13:50
  • @TheLinuxGK Strange! Mine is exactly the same (I'm in a GNOME session). But I have another gnome-software-service.desktop file in ~/.config/autostart with an extra X-GNOME-Autostart-enabled=false line. – pomsky Oct 18 '17 at 14:55
3

From https://ask.fedoraproject.org/en/question/92941/how-to-stop-fedora-24-gnome-software-auto-updating/, try these two options:

  1. Disable it in gsettings

    gsettings set org.gnome.software download-updates false
    
  2. If that fails .. mask (disable) the backend service, PackageKit, the service used by Gnome Software.

    sudo systemctl mask packagekit.service
    
|improve this answer|||||
  • Following your instructions, I noticed that upon bootup, gnome software is seen loaded at system-monitor, and after some seconds it exits. This solves the ram-consume-problem but slowing-bootup persists. – TheLinuxGK Sep 25 '17 at 19:02
  • 1
    Debugging boot is different. Did you mask packagekit ? Debugging boot is almost another question, but did you run blame ? dedoimedo.com/computers/systemd-blame.html – Panther Sep 25 '17 at 19:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.