16

Like it says in the title. Fresh XFCE install over Ubuntu. Whenever I try to change the clock format through Right-Click>Panel>Preferences, the clock disappears as soon as I close the window. I have to go back to Panel Preferences and remove and re-add the clock applet to make it come back, and then my format changes never stick.

Is there a fix for this, or possibly a less buggy clock applet for the panel I could be using?

  • I'm using xfce 4.12 and have the exact same issue, on Linux Mint 19. – dotnetCarpenter Aug 3 '18 at 12:02
  • 1
    Same issue for me for Xubuntu 18.04 64-bit. – Shule Aug 24 '18 at 23:42
  • For me, Xubuntu 18.04.1 64bit does NOT have the issue, but if I install xfce4-session, xfce4-panel, xfwm4, etc. in stock Ubuntu, then the clock will lose its config as described. Not sure what the solution is but somehow Xubuntu has addressed the issue. – rik-shaw Jan 12 '19 at 6:58
  • 3
    Change your clock settings without pressing close, then run xfce-panel -r which resets the panel application. – Ali Caglayan Jan 29 '19 at 14:10
  • related bug with some suggested workarounds: bugzilla.xfce.org/show_bug.cgi?id=14507 – Kevin Bowen Apr 30 '19 at 21:59
13

I had the same problem and found a workaround.

Right click the clock panel (or access from panel preferences) and set the configuration you want but do NOT close the properties window. Instead, while leaving it open, logout and log back in. The clock should reappear with the preferences you set. For some reason closing the properties window seems to reset the settings to blank custom fields, which makes the clock disappear.

  • 3
    Another workaround I found was to just set the custom format you want, even if it's the same as one of the built in formats. The format specifiers are documented at docs.xfce.org/xfce/xfce4-panel/clock. Annoying that you have to do this, but it does seem to work. – Tim Destan Feb 15 '18 at 23:05
  • 1
    Thanks to both of you. I've found that if you just want to use one of the predefined formats but can't due to this bug. Then you can select the predefined format and then select "Custom Format" - the format code is automatically inserted and you can close the window. BTW the code for HH:MM is %R. – dotnetCarpenter Aug 3 '18 at 12:12
7

My way around this was to set it to what I want. and without closing the clock properties.

I open terminal and run this command

killall xfce4-panel

followed by this command

xfce4-panel & 

Then you can close terminal (which may make the panel refresh again). But my settings I picked for my clock remained. The properties thing is just all kinds of borked up. It was broken like this while it was still a beta. Figured it be fixed by the time it it was released. But nope, clearly no.

6

Best workaround as commented by https://askubuntu.com/users/513351/ali-caglayan but as an answer:

Change the properties but don't close the window.

then restart the panel,

xfce4-panel --restart
1

I just ran into the same thing (I'm brand new to XFCE). The panel clock seems to be very sensitive to configuration changes. Some settings combinations simply don't work and the clock disappears. I found the Items tab in the Panel Preferences dialog and discovered that I had wound up with seven instances of the panel clock running; all displaying nothing. I deleted them and installed the Orage Panel Clock which was bundled with XFCE. It's been working fine since.

0

As a workaround, don't close the Panel Preferences window with the Close button when you're done. Instead close the window with the "X" button to the top right.

  • This does not provide an answer to the question. To critique or request clarification from an author, leave a comment below their post. - From Review – mature Jun 16 '19 at 20:43
  • Did you try my solution? This question has a simple answer and this answer must be accepted i think. – kodmanyagha Jun 16 '19 at 20:48
  • 1
    not working in my case – cipricus Sep 25 '19 at 18:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.