0

I have a Dell 15 l502x with NVIDIA GeForce GT525M with Optimus in it. I installed a fresh Ubuntu 16.04 LTS on it but am unable to use the NVIDIA card. 2 observations: 1. All NVIDIA drivers installation fail, I have tried many versions. I saw this error: W: Possible missing firmware for module i915. It gets stuck in the login screen loop after reboot. 2. Settings show that the graphics card is 'Gallium 0.4 on llvmpipe (LLVM 4.0, 256 bits)'. When I do 'sudo apt-get install xserver-xorg-video-intel' , it throws this error: the following packages have unmet dependencies: xserver-xorg-video-intel : Depends: xorg-video-abi-20 Depends: xserver-xorg-core (>= 2:1.17.99.902) E: Unable to correct problems, you have held broken packages.

Background: I had Ubuntu 14.04 LTS before this where I tried installing ROS. I do remember it saying something like, some packages could destroy my Xserver. But, I installed Ubuntu 16.04 over 14.04 as fresh install, without updating. I apologize, I am a little new.

  • 1
    Open Additional Drivers, select the recommended Nvidia driver. Apply. Reboot. – user692175 Sep 25 '17 at 17:15
  • Hi Michael Bay, thanks, but I have tried that. Nothing shows up as recommended. It is a list of different driver versions from Nvidia and some Xserver based. I have tried installing different versions of Nvidia drivers, both from GUI as well as from terminal. It enters into a login windows loop after that. So, then I go to TTY, purge nvidia drivers and am back to where I started. – pahadi_bhula Sep 26 '17 at 18:37
  • Check here geforce.com/drivers what versions support the GT525M, then fully update your system, open Additional Drivers and choose accordingly. If it doesn't work you have other issues going on. – user692175 Sep 26 '17 at 18:41
  • Yes, Michael I am thinking 2 problems: 1)My graphics card is based on Optimus which create a problem even if the graphics driver page says it is supported. 2)I am getting this error when I try to install drivers: W: Possible missing firmware /lib/firmware/i915/kbl_dmc_ver1_01.bin for module i915 – pahadi_bhula Sep 27 '17 at 11:10
  • Not an error, "W" stands for "warning" and it can be ignored. It has nothing to do with the Nvidia part anyway. PS: I'm aware of the hybrid graphics and it nothing to do with it. For managing and switching between Intel/Nvidia you need to install the Nvidia proprietary drivers and switch using the profile at Nvidia X Server Settings (reboot required). – user692175 Sep 27 '17 at 15:40
0

This worked for me: 1. Update package lists

sudo apt-get update
  1. Remove nouveau

    sudo apt-get remove xserver-xorg-video-nouveau

  2. Install bumblebee, primus and NVidia Drivers

    sudo apt-get install bumblebee-nvidia nvidia-384

  3. Blacklist NVidia Drivers in your /etc/modprobe.d/bumblebee.conf i.e add towards the end of file ' # 384 blacklist nvidia-384 blacklist nvidia-384-updates blacklist nvidia-experimental-384 '

  4. Update bumblebee Config to Point to 384.x Drivers in /etc/bumblebee/bumblebee.conf ....Driver=nvidia ... LibraryPath=/usr/lib/nvidia-384:/usr/lib32/nvidia-384 ... XorgModulePath=/usr/lib/nvidia-384/xorg,/usr/lib/xorg/modules ...

  5. Select Mesa as your GL Provider

    sudo update-alternatives --config i386-linux-gnu_gl_conf Select /usr/lib/i386-linux-gnu/mesa/ld.so.conf

    sudo update-alternatives --config x86_64-linux-gnu_egl_conf Select /usr/lib/x86_64-linux-gnu/mesa-egl/ld.so.conf

    sudo update-alternatives --config x86_64-linux-gnu_gl_conf Select /usr/lib/x86_64-linux-gnu/mesa/ld.so.conf

  6. Reboot

    sudo reboot

  7. Disable gpu-manager i.e Add nogpumanager to your /etc/default/grub file ... GRUB_CMDLINE_LINUX="nogpumanager" ...

  8. Update your grub menu

    sudo update-grub

  9. Re-build the bbswitch and nvidia modules.

    sudo dpkg-reconfigure bbswitch-dkms sudo dpkg-reconfigure nvidia-384

  10. Reboot

    sudo reboot

Source: http://lenovolinux.blogspot.co.uk/2016/05/bumblebee-on-lenovo-t440p-nvidia-gt.html?m=1

  • 1
    While this link may answer the question, it is better to include the essential parts of the answer here and provide the link for reference. Link-only answers can become invalid if the linked page changes. - From Review – ravery Oct 9 '17 at 23:21
  • Thanks @ravery I have updated the post now. Please let me know if this is fine now, or needs modification. – pahadi_bhula Dec 3 '17 at 18:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.