0

I have an Epson XP-225 multifunctional device. I have installed all the required drivers from Epson website as well as used advice from this post

I can print without problems however I cannot scan at all as the scanner is not detected. I tried to scan with uwf stopped using: IScan , Simple Scan, IScan for Linux (came with one of the epson packages) and XSane.

I tried running

Sudo Xsane

However still no scanner detected. I do not have capacity to move the device nor run long usb cable to connect to my computer plus it defies the purpose of wifi connectivity of the device. Scanner definitely works as tested on Win 7, 8, 10 and XP as well as Android devices using epson scan app and on apple products (macbook pro and Ipad 2)

Any ideas on how to sort this?

Lenovo Thinkpad Edge E555 Ubuntu 16.04 LTS

2

With admin privileges, edit /etc/sane.d/epkowa.conf.
add the line:

`net 192.168.X.XX'

Replace the X's with the actual location of your printer.
This should allow iscan to find your scanner.

| improve this answer | |
  • Hi Ravery, thank you for response. After modifying epkowa.conf Iscan returns: Could not send command to scanner. Check the scanner status. – Simple Glasgow Sep 25 '17 at 18:36
  • Is iscan-network-nt installed? it should have come with the iscan driver package from epson. Also check, /etc/sane.d/dll.config, be sure there is a line that says 'net'. and verify the config used by iscan, /etc/sane.d/dll.d/iscan – ravery Sep 25 '17 at 18:51
  • iscan-network-nt is in the newest version. /etc/sane.d/dll.conf does have the net line /etc/sane.d/dll.d/iscan does have epkowa and net lines not commented – Simple Glasgow Sep 25 '17 at 19:00
  • /etc/sane.d/dll.d/iscan as a net line in it?Mine only has epkowa, and verify you have the right IP for the printer. PS the printer has to be on not in sleep mode. – ravery Sep 25 '17 at 19:10
  • Scanner is awake, IP is from the network status printout from the printer and matches the one in printer setup (for printing) as well as one directly from the router. Iscan had originally net line, modified it to net 192.158.1.69 then again removed net line completely and still the same – Simple Glasgow Sep 25 '17 at 19:16
0

I have reinstalled my O.S. then done all the required installs. I must've had something missing. I edited epkowa.conf to add the line net 192.168.1.69 and it all works now. Thank you again

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.