3

I got my new Dell Inspiron 15 3565 preloaded with Ubuntu 16.04 LTS.

I'm first time user of Ubuntu. All working fine except the WiFi. It doesn't respond after 10 minutes. If I reboot the laptop it is back to action again, but for the next 10 minutes.

Can someone help me to find the problem and solve it?

Here is the result of lspci -knn | grep Net -A3; rfkill list:

$ lspci -knn | grep Net -A3; rfkill list
16:00.0 Network controller [0280]: Intel Corporation Wireless 3165 [8086:3165] (rev 79)
    Subsystem: Intel Corporation Wireless 3165 [8086:4410]
    Kernel driver in use: iwlwifi
    Kernel modules: iwlwifi
0: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no
1: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no

Output of wireless info script

Here is the result of the Network Diagnostics when the wifi had stopped working:

--2017-09-26 12:24:29--  https://github.com/UbuntuForums/wireless-info/raw/master/wireless-info
Resolving github.com (github.com)... failed: Connection timed out.
wget: unable to resolve host address ‘github.com’
  • 1
    Welcome to Ask Ubuntu! Could you please run the network diagnostics and edit your question to include a link to the result? I know it may seem a bit overwhelming for a novice but your info so far is a bit vague and the diagnostics will likely cover all options that may cause your issue. Thanks. – David Foerster Sep 25 '17 at 7:22
  • 1
    Please edit your question and add output of lspci -knn | grep Net -A3; rfkill list terminal command. – Pilot6 Sep 25 '17 at 9:44
  • Just a hint: You can save the network diagnostics script locally on the computer to run it later without internet access, save the result to a local file and upload that file once internet works again or by copying it to an external drive an uploading it with a different machine. – David Foerster Sep 26 '17 at 12:37
1

Sorry for the very late answer, but just in case someone else was having the same issue, using tlp is the answer. I have just recently installed Ubuntu 18.04, onto a Dell Inspiron 15 3565 and had very similar wifi issues. The laptop was also having additional power issues such as the screen intermittently turning off. After installing and slightly altering the tlp config file, the computer now runs very smoothly on battery power.

The issue was fixed using these few steps:

  1. Installing the tlp power manager.

    To install tlp:

    sudo add-apt-repository ppa:linrunner/tlp
    sudo apt-get update
    sudo apt-get install tlp tlp-rdw 
    
  2. Unfortunately the default battery setting using tlp didn't fix the issue, though after changing some settings in the config file, the issues were fixed.

    To open the config file:

    sudo nano /etc/default/tlp
    
  3. Within the config file, changing the ON_BAT settings to be the same as ON_AC has made all the difference. Changing these settings has stopped the wifi disconnections as well as the other power issues the Dell was suffering from.

    These are the changes:

    CPU_HWP_ON_BAT=balance_performance
    SCHED_POWERSAVE_ON_BAT=0
    ENERGY_PERF_POLICY_ON_BAT=performance
    WIFI_PWR_ON_BAT=off
    

After altering the battery settings to be more like AC, I was expecting a considerably shorter battery life. This hasn't been the case :)

0

Ubuntu had always had many problems with WiFi, but given that your hardware is officially supported and it has intel wifi chip, I suspect it is not related to hardware. I know one Ubuntu bug that is similar to what you describe: Bug #1586528
Symptoms are:
1. Network connection is lost and there is a messages like avahi-daemon[xxx]: Withdrawing address record for xx.xx.xx.xx on interface_name in /var/log/syslog. You can check for it by doing: grep avahi-daemon /var/log/syslog | grep -i withdrawing 2. You can restore wifi connection by doing: sudo ifconfig wifi_interface down sudo ifconfig wifi_interface up If you don't know the name of your WiFi interface use ifconfig command, it will list all available interfaces.

Check if this is the bug, that affects you. If so, follow provided link. The bug is not fixed, sadly, but as you will see there is a workaround, which requires you to disable IPv6.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.