1

Hello my dear Linux users,

I run Ubuntu 14.04 and I have gcc-7 installed using the Toolchain test builds.

When I start VM Player 12.5.7 build-5813279 it is asking for gcc 7.2. I point it to /usr/bin/gcc-7 but it says that this gcc version is not compatible.

Any ideas on how to make this work?

enter image description here

  • Please run sudo update-alternatives --config gcc and paste into your question – George Udosen Sep 25 '17 at 6:08
  • Are linux headers files installed if not install: sudo apt-get install linux-headers-$(uname -r) – George Udosen Sep 29 '17 at 17:28
  • I'm currently in aptitude. There seem to be several unmet dependies: binutils >=2.26.1, cpp-7 =7.2.0, libisl15 >=0.15, lipmc3, lipmfr4 >=3.1.3 ...The problem is that aptitude keeps saying that these dependencies are unavailable. I have been trying to add them to the install list in aptitude. – johann_ka Sep 29 '17 at 17:49
  • Yes, header files are installed: linux-headers-4.13.4-041304-lowlatency – johann_ka Sep 29 '17 at 17:49
  • Try sudo dpkg --configure -a, then sudo apt-get update then sudo apt-get install -f – George Udosen Sep 29 '17 at 17:50
4

I solved via the : cd /usr/lib/vmware/modules/source tar -xf vmnet.tar cd vmnet-only make cd .. tar -xf vmmon.tar cd vmmon-only make cd .. cp vmmon.o /lib/modules/`uname -r`/misc/vmmon.ko cp vmnet.o /lib/modules/`uname -r`/misc/vmnet.ko depmod -a /etc/init.d/vmware restart

One may need to use sudo before each command above.

While running make during the above command execution, if there is an error, search the error in vmware community for a patch. For example i solved one issue using the following patch :

diff -Naur vmnet-only.orig/bridge.c vmnet-only/bridge.c --- vmnet-only/bridge.c 2017-06-26 22:08:39.148034785 +1000 +++ vmnet-only/bridge.c 2017-07-16 11:37:01.325802125 +1000 @@ -636,7 +636,7 @@ unsigned long flags; int i; - atomic_inc(&clone->users); + clone = skb_get(clone); clone->dev = dev; clone->protocol = eth_type_trans(clone, dev);

If you have the version.h file missing in your vmware log, try below code:

cd /usr/src/kernels/$(uname -r)/include/linux/ ln -s /usr/include/linux/version.h version.h

Note: I got all the above information from the Internet Now i can launch VMWare player

| improve this answer | |
  • This also works for any of the version mismatch of vmmon/vmnet.ko and other related issues. I recompiled and copied manually as above. It worked in my case as well. This is for the current latest VMware Player v14. – user194850 Jan 13 '18 at 7:00
0

I had the same issue with VMWARE 12.5.8 with GCC 7.2.0 . I followed the steps mentioned by sandoche balakrichenan and I face some issues while making the vmmon-only folder. I had to do a few additional steps to get vmware working.

Here are my steps :

cd /usr/lib/vmware/modules/source
tar -xf vmnet.tar
cd vmnet-only
make
cd ..
tar -xf vmmon.tar
cd vmmon-only
make

[faced some issues and couldn't create the vmmon.o file. RFollowed steps from here -> here Copied these from this GITHUB -> here into the /usr/lib/vmware/modules/source folder]

cd ..

[Create the misc folder if necessary]

cp vmmon.o /lib/modules/`uname -r`/misc/vmmon.ko
cp vmnet.o /lib/modules/`uname -r`/misc/vmnet.ko
depmod -a
/etc/init.d/vmware restart

Worked like a charm! Thanks!

| improve this answer | |
-1

In my experience with this, you should click the "OK" button on the pop up. The VMware Kernel Module Updater should come up again. Just point it to your gcc-7 again. It should compile. If that still fails you will need to have to install gcc-7.2. This will be from the Toolchain test builds. Use these commands:

sudo apt-get update -y && \
sudo apt-get upgrade -y && \
sudo apt-get dist-upgrade -y && \
sudo apt-get install build-essential software-properties-common -y && \
sudo add-apt-repository ppa:ubuntu-toolchain-r/test -y && \
sudo apt-get update -y && \
sudo apt-get install gcc-7 g++-7 -y && \

This part must be done:

sudo update-alternatives --install /usr/bin/gcc gcc /usr/bin/gcc-7 60 --slave /usr/bin/g++ g++ /usr/bin/g++-7 && \

Now:

sudo update-alternatives --config gcc

NOTE:

This works on Debian as well but instead of adding the Ubuntu repo you can add:

deb http://ftp.us.debian.org/debian testing main contrib non-free

to the end of:

/etc/apt/sources.list

Now try the VMware Kernel Module Updater again. You may just see gcc-7 only. Just point there; it will be gcc-7.2. If the incompatible warning comes up, do as I stated above.

Hope this helps,

| improve this answer | |
  • gcc-7.2.0 is installed on my system. Repeatedly trying to make VM Player pick gcc-7.2.0 does not work. – johann_ka Sep 25 '17 at 5:59
  • Did you follow my guide? This was what I had to do every time I updated the kernel. – Dave Sep 25 '17 at 6:06
  • @johann_ka Please run sudo update-alternatives --config gcc and paste into your question – George Udosen Sep 25 '17 at 6:11
  • Since you have gcc-7 installed using the Toolchain test builds, I would give the gcc-7.2 a try from repository ppa:jonathonf. – Dave Sep 27 '17 at 0:08
  • @George - the output of sudo update-alternatives --config gcc is update-alternatives: error: no alternatives for gcc ..I have been trying to get this back (registering gcc) but so far unsuccessful. – johann_ka Sep 29 '17 at 17:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.