0

Before few weeks back I tried to install openmotif or lesstif2 to support my Monte Carlo simulation package. But the installation was failed due to a dependency error and I have given up installation.

But now i realized, when I tries to install any package this lesstif2 dependency error comes up and prevent all type of installation. I tired to upgrade python 2.7 to 3.6 and this massage was given.

Can some one please help me to solve this problem.

manoj@manoj-Inspiron-N5050:~$ sudo apt-get install python3.6
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
lesstif2 : Depends: libxp6 but it is not installable
python3.6 : Depends: python3.6-minimal (= 3.6.2-1~16.04.york0) but it is  not going to be installed
Depends: libpython3.6-stdlib (= 3.6.2-1~16.04.york0) but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

Thanks Manoj

Update

I tried to install both lesstif2 and openmotif as well but it was also failed due to dependency error

  • try sudo apt-get update && sudo apt-get -f install – Panther Sep 25 '17 at 3:32
  • Install libxp6 - stackoverflow.com/questions/42350781/… – Panther Sep 25 '17 at 3:47
  • Thanks bodhi..your first suggestion worked. It removed the lesstif2 from the system and allowed to install python 3.6. I have one more question..Is it a good idea to change default python 2.7 compiler to python 3.6 and install anaconda or should i stick to the 2.7..because i found some comment suggesting that! Thanks for your help and motif guide.. I ll try it – Manoj Sep 25 '17 at 3:56
  • @Manoj If you have another question please post it as this isn't a forum. – user692175 Sep 26 '17 at 1:00