2

I have a problem with my wi-fi connection.

I use the TP-Link TL-WN823N wifi adapter, which connects to Alcatel Link Zone MW40V wifi router. OS is Ubuntu Xenial.

It works fine for a while, and for some reason, I stops, then it gets back to working. It may work for hours, but sometimes only like 10 minutes.

The usb device isn't "lost" or something, the "strength signal" is still like 90/100

Someone suggested me looking at /var/log/syslog and I think I have at least two problems, to begin with. I do have a lot of these:

Sep 24 11:41:19 konrad kernel: [131012.924347] RTL871X: rtw_set_ps_mode(enxd46e0e147875) Enter 802.11 power save - WIFI-TRAFFIC_IDLE
Sep 24 11:41:19 konrad kernel: [131012.924359] RTL871X: rtl8192e_set_FwPwrMode_cmd: Mode=2 SmartPS=2 UAPSD=0
Sep 24 11:41:19 konrad NetworkManager[822]: <warn>  [1506246079.6088] (wlan0): error getting signal strength: No such device
Sep 24 11:41:21 konrad kernel: [131014.928441] RTL871X: rtw_set_ps_mode(enxd46e0e147875) Leave 802.11 power save - WIFI-TRAFFIC_BUSY
Sep 24 11:41:21 konrad kernel: [131014.928451] RTL871X: rtl8192e_set_FwPwrMode_cmd: Mode=0 SmartPS=2 UAPSD=0
Sep 24 11:41:23 konrad kernel: [131016.932286] RTL871X: rtw_set_ps_mode(enxd46e0e147875) Enter 802.11 power save - WIFI-TRAFFIC_IDLE
Sep 24 11:41:23 konrad kernel: [131016.932297] RTL871X: rtl8192e_set_FwPwrMode_cmd: Mode=2 SmartPS=2 UAPSD=0
Sep 24 11:41:25 konrad NetworkManager[822]: <warn>  [1506246085.6072] (wlan0): error getting signal strength: No such device
Sep 24 11:41:31 konrad NetworkManager[822]: <warn>  [1506246091.6080] (wlan0): error getting signal strength: No such device
Sep 24 11:41:37 konrad NetworkManager[822]: <warn>  [1506246097.6046] (wlan0): error getting signal strength: No such device
Sep 24 11:41:43 konrad NetworkManager[822]: <warn>  [1506246103.6078] (wlan0): error getting signal strength: No such device
Sep 24 11:41:49 konrad NetworkManager[822]: <warn>  [1506246109.6042] (wlan0): error getting signal strength: No such device
Sep 24 11:41:51 konrad kernel: [131044.988390] RTL871X: rtw_set_ps_mode(enxd46e0e147875) Leave 802.11 power save - WIFI-TRAFFIC_BUSY
Sep 24 11:41:51 konrad kernel: [131044.988402] RTL871X: rtl8192e_set_FwPwrMode_cmd: Mode=0 SmartPS=2 UAPSD=0
Sep 24 11:41:53 konrad kernel: [131046.992232] RTL871X: rtw_set_ps_mode(enxd46e0e147875) Enter 802.11 power save - WIFI-TRAFFIC_IDLE

Side note: the "error getting signal strength" appeared recently afaik, before it wasn't there, yet problems existed as well.

Regarding the 'power save...' things, someone adviced me to set

[connection]
wifi.powersave = 2

In file /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf (It used to be 3 before). I did it, and rebooted the entire machine. But it didn't changed anything.

So, how to get rid of these messages? I think this is how I should start solving the main issue?

p.s. This is the result of the Wireless Info Script ( My wireless/WiFi connection does not work. What information is needed to diagnose the issue? ), created when the connection was OK:

http://paste.ubuntu.com/25609509/

2
  • You may try this following thread raspberrypi.stackexchange.com/questions/34794/… – ob2 Sep 24 '17 at 19:33
  • @olivierb2 - I'm stuck on the first step, i.e. $iw wlan0 get power_save - instead of getting the result, I get a 'iw' command help ('usage'), just like entered some bad command :( – konrados Sep 25 '17 at 0:13
2

Edit 1.5 year later:

Actually I finally solved the issue by... moving my wi-fi adapter higher :) I.e. before that, the device was connected directly to a PC, in the back. I used a 1m USB extension cable to move it away from a computer. And in the same time, put it higher. Now it seems obvious for me, it wasn't back then, when I asked the question :)

But the below answer did help too, just not in 100%.

Someone suggested doing the following. Create the following file:

 /etc/modprobe.d/8192eu.conf

And add the following line:

options 8192eu rtw_power_mgnt=0 rtw_enusbss=0 rtw_ips_mode=0

From what I have found, the meaning of the options is like this:

-Disable power management:

options 8192eu rtw_power_mgnt=0

-Disable USB autosuspend:

options 8192eu rtw_enusbss=0

-Disable power management:

options 8192eu rtw_ips_mode=0

This helped with entering the sleep mode repeatedly problem, which improved the overall situation, although not solved it in 100% percent. This is, however, a topic for another question.

One of the sources: https://forum.manjaro.org/t/solved-rtl8192-wifi-performance-problem-after-last-stable-update/25481

2
  • Thanks. Though this worked only partially. Now I get this every 1m while it's connected: ` Mar 28 07:27:07 foo kernel: [ 319.968669] RTL871X: SetHwReg8192E(enx98ded01a7873): [HW_VAR_MACID_SLEEP] macid=0, org reg_0x4d4=0x00000000 Mar 28 07:27:08 foo kernel: [ 321.390124] RTL871X: survey done event(2e) band:0 for enx98ded01a7873 Mar 28 07:27:08 foo kernel: [ 321.390142] RTL871X: rtw_indicate_scan_done(enx98ded01a7873) ` – Normadize Mar 28 '18 at 6:27
  • Actually the SLEEP message seems independent. How can one get rid of that too? I don't need the dongle to survey the wifi networks while it's already connected to one. – Normadize Mar 28 '18 at 6:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.