14

When I use Google Chrome (currently 61, but the error exists before), I constantly get ERR_NETWORK_CHANGED. Often, the webpage reloads and works a second later, but often things simply don't work. For example, I'm not able to download files from Google Drive at all, because a XHR call fails with this error (this is an example. The error is not specific to Google Drive). Social logins with Google / Facebook are not possible, because the callback after the login are failing, too. The problem exists in incognito mode, too.

With Firefox, there seem to be no problems.

On Ubuntu 16.04, the problem doesn't exist.

Ethernet controller is a I219-V. Not able to try other machines.

While writing this, I found out that disabling the IPv6 privacy extensions with

sudo sysctl -w net.ipv6.conf.enp0s31f6.use_tempaddr=0

and restarting the interface seem to be a workaround solve the problem, but obviously it's bad to use workarounds instead of solving the root problem.

  1. Whats going on here? Why does this affect Chrome and not Firefox? What is the difference?
  2. Whats the difference between Ubuntu 17.04 and 16.04 regarding this problem?
  3. How can I get more information about the problem?
  4. Is this a known problem with Ubuntu 17.04?
  • Hi! I have the same issue with 16.04 but only AFTER I updated the kernel for the meltdown bug. And for the 14.04, again, only after meltdown patch. – visoft Jan 16 '18 at 7:59
  • For both wired and wireless controller, the net.ipv6.conf...use_tempaddr is 0. – visoft Jan 16 '18 at 8:03
  • if you are using docker as https://askubuntu.com/a/909631/938234 said remove useless docker networks and everything will be fine. it worked for me. – milad mohebnia Mar 30 '19 at 13:56
22

For anyone else that probably didn't think of it like me - this was being caused by a docker container I had running on the machine.

| improve this answer | |
  • 4
    What did the docker container do? Just run? – phihag Nov 13 '19 at 12:18
  • 1
    This worked for me. The container in question may have been failing and restarting endlessly since boot but was otherwise unremarkable. docker ps; docker update <container_id> --restart=no; – bbeecher May 4 at 23:02
3

Making a js request while starting a docker container seems to trigger this kind of error. Somehow connected with the docker network, when containers are dynamically added/removed. Chromium only, not seen on Firefox.

| improve this answer | |
0

This still happens in Ubuntu 18.04 and Google Chrome Stable (80.0.3987.106 now).

Disabling Docker reduces (not eliminate) this issue, and using sysctl to disable use_tempaddr also reduces too (still didn't eliminate).

I need to totally disable IPv6 to avoid this issue, by changing /etc/default/grub from:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

To:

GRUB_CMDLINE_LINUX_DEFAULT="ipv6.disable=1 quiet splash"

Then running Docker would be fine.

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.