9

Skype for Linux Beta shows the following message when running the application. Is there a new version of Skype for Linux?

Sorry, this version of Skype is not supported anymore.

How can I get it work?

  • what version are you running? – ravery Sep 24 '17 at 6:33
  • It is microsoft software... use windows in a virtual machine for the better experience. – Rinzwind Sep 24 '17 at 6:50
  • 3
    It looks like something prevents that automatic upgrade of the skypeforlinux package on your system. Could you please edit your question to include the output of sudo apt-get update && sudo apt-get upgrade -f --assume-no; apt-cache policy skypeforlinux? Thanks. – David Foerster Sep 24 '17 at 8:58
  • The problem is already fixed. I followed the method mentioned by @dessert. But ubuntu didn't take sudo add-apt-repository deb repo.skype.com/deb stable main command, so I had to remove stable main from the command. Later, I put those values from Software Repo interface. Seems like the default repo is xenial which didn't work. After making the changes for the repo (stable and main), and with update and upgrade, Skype worked. Seems like the official version for linux of skype is skype preview now. – SushilB Sep 25 '17 at 7:09
16

Skype.com says:

Important notice: All Skype for Linux clients version 4.3 and older will be retired on July 1, 2017. To keep chatting, please install the latest version of Skype for Linux.

It's enough to add the official skypeforlinux source and upgrade your current installation with these commands:

sudo add-apt-repository "deb https://repo.skype.com/deb stable main"
sudo apt update && sudo apt upgrade

Alternatively, remove it with sudo apt remove skypeforlinux and install the current version from here. This will also add the source for updates to your sources, thus keeping the program automatically updated.

On upgrading to 17.10 the skype repository might get disabled so that you need to reenable it either in the Software Center or by editing /etc/apt/sources.list (do that only if you know what you do).

| improve this answer | |
  • Adding repository and updating worked for me. Thanks. – SushilB Sep 24 '17 at 8:50
  • This was essentially the problem for me. I already had the repository, but it had been disabled on upgrade to artful. I simply re-enabled it in the Other Software tab of my package manager GUI and then command line sudo apt update && sudo apt upgrade upgraded my Skype For Linux to version 8.11.0.4. – schester Dec 2 '17 at 6:34
  • 1
    To clarify: One might still have the old Skype version (4.3) installed and be executable as skype, and one should run the new skypeforlinux executable. – datka Dec 5 '17 at 8:54
  • Is the add-apt-repository command correct (the white spaces look strange to me)? – Cleb Jan 1 '18 at 23:03
  • Note that the old name was skype. You need to remove that one and install skypeforlinux. – Alan Thompson Feb 1 '18 at 22:45
3

In 32 bit linux, make skype a "higher" version:

sudo sed -i 's/4\.3\.0\.37/8\.3\.0\.37/' /usr/bin/skype

It replaces the version number in the binary for a higher one to work around the forced incompatibility. Make sure that you have the same version 4.3.0.37 by calling skype --version or update the command accordingly. Thanks to YuriyKuzin.

| improve this answer | |
  • 2
    I'd rather advise the use of a hex editor instead of sed as this could go horribly wrong. And please if you stick to this answer use -i.bak so at least a backup of the file is made before the change. – Videonauth Dec 2 '17 at 8:33
  • According to @Videonauth's advice, I have done this with a hex editor. There was precisely one instance of the version number in the file. After replacing that, I can now run Skype 4.3 without any problems. This may or may not work for Beta 5.5 which is the object of the question, but it most certainly applies to at least one other question that was closed as a duplicate of this one: askubuntu.com/questions/975804/skype-crashes-after-logging-in Therefore, you get an upvote. – hife Dec 5 '17 at 17:51
  • Awsome! Works like charm @14.04 64-bit – ataraxic Jan 24 '18 at 14:15
  • It would have been great to see this before uninstalling skype..., still +1 – serv-inc Feb 24 '18 at 9:57
  • I successfully performed the edit with GHex editor, replacing multiple instances of "4.3.0." with "8.3.0." It still reports version "4.3" in the window title when Skype starts up, but at least it runs now. Before the edit, Skype would appear to start after the log-in dialogue, then would suddenly quit with no indication of what had happened. – Andrew P. Apr 1 '18 at 5:45

Not the answer you're looking for? Browse other questions tagged or ask your own question.