Today I installed Ubuntu 11.10 x64 on to my lenovo B570 using wubi.exe. After booting up, I discovered that I could not turn on wireless networking. I have a Atheros AR9285 wireless card.

I ran through the Ubuntu wireless troubleshooting guide, and the output suggest that the card has a driver, but it simply wont turn on! (I will post this soon.)

linuxwireless.org seems to have an archive of drivers called compat-wireless which is purported to fix this issue, but I'm new to Linux and don't know how to install them.

LBM may also be an solution, but I'm having difficulty downloading and installing the package.

There have been several post about driver issues with this card before, but all of the solutions assume wired internet access, or I simply don't understand them.

Any help will be greatly appreciated!

What I've tried so far:

  • Installed Linux Backport Modules today. Wifi is still not working.
  • Installed compat-wireless. Wifi is still not working.

Additional information:


NetworkManager Tool 

State: disconnected 

- Device: wlan0 ---------------------------------------------------------------- 
  Type:              802.11 WiFi 
  Driver:            ath9k 
  State:             unavailable 
  Default:           no 
  HW Address:        74:DE:2B:84:86:A2 


  Wireless Properties 
    WEP Encryption:  yes 
    WPA Encryption:  yes 
    WPA2 Encryption: yes 

  Wireless Access Points

sudo lshw -c network

*-network DISABLED      
       description: Wireless interface 
       product: AR9285 Wireless Network Adapter (PCI-Express) 
       vendor: Atheros Communications Inc. 
       physical id: 0 
       bus info: pci@0000:02:00.0 
       logical name: wlan0 
       version: 01 
       serial: 74:de:2b:84:86:a2 
       width: 64 bits 
       clock: 33MHz 
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless 
       configuration: broadcast=yes driver=ath9k driverversion=3.0.0-12-generic firmware=N/A latency=0 link=no multicast=yes wireless=IEEE 802.11bgn 
       resources: irq:17 memory:d0500000-d050ffff

sudo lspci |grep Atheros

02:00.0 Network controller: Atheros Communications Inc. AR9285 Wireless Network Adapter (PCI-Express) (rev 01) </pre>

<pre>sudo lsmod |grep ath 
ath9k                 127538  0 
mac80211              310872  1 ath9k 
ath9k_common           13839  1 ath9k 
ath9k_hw              312866  2 ath9k,ath9k_common 
ath                    24067  2 ath9k,ath9k_hw 
cfg80211              199587  3 ath9k,mac80211,ath 

sudo iwconfig

lo        no wireless extensions. 

eth0      no wireless extensions. 

wlan0     IEEE 802.11bgn  ESSID:off/any  
          Mode:Managed  Access Point: Not-Associated   Tx-Power=14 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off 
          Encryption key:off 
          Power Management:off

locate -i ath9k


After some research, I'm fairly certain Atheros' ath9k driver is worthless, and needs to be replaced. Since I already tried this with LBM and compat-wireless, I will look for an older version of the ath9k driver. I'm not sure what MadWifi is but it warrants looking into as well. Also looking into turning off softblock.

Hasn't someone already fixed this issue?

  • It's not about interest, as the upvotes to your question prove, the problem is that the question is too localized. It's likely that only people with both your same card and good linux and hardware knowledge can help you. Jan 19, 2012 at 8:15

1 Answer 1


This was fixed with:

sudo modprobe -r acer-wmi
cd /etc/modprobe.d
sudo nano blacklist.conf

Then add blacklist acer-wmi as a new line at the end of the file.

which was posted earlier by fossfreedom

Thanks fossfreedom!!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .