1

I've installed windows 10 and then Ubuntu 16.04 but grub options doesn't load. When I hit Fn + F9, it shows the windows only. When I boot the USb with the Ubuntu installation, it shows that I have both Windows and Ubuntu installations and I can see the partitions.

I've tried this: bcdedit /set {bootmgr} path \EFI\ubuntu\grubx64.efi

but it didn't work.

I can log into Ubuntu, only in windows.

Is there any way to fix that?

1

I've had the same exact problem 3 days ago and I just solved it. But, it can happen due to many different reasons:

  1. The Secure Boot option is enabled on your BIOS Setup menu. Dual boot usually doesn't work with secure boot. To disable it, you need to access your BIOS Setup menu by restarting you computer and pressing the F2 key when it starts again (every computer works differently so you can find details on your computers manufacturer's website), look for the Boot configuration (it's usually on a separate tab), find the Secure Boot option and set it to "disabled".

OBS 1: It's usually better to install the second OS with Secure Boot already disabled.

  1. If your Ubuntu boot loader was successfully installed, disabling the secure boot will probably be enough to start your computer and access GRUB (the Ubuntu boot manager). But, if that does not work, you can access your BIOS Setup menu once again and change the boot priority with Ubuntu on top. This way, the computer loads Ubuntu first, which recognizes Windows so you can choose which one to use.

  2. The code you used works when you have Secure Boot disabled. Personally, I think it's not the best option to change the boot manager of Windows in order to access the Ubuntu boot loader, but if you still wanna do it, you can disable the Secure Boot and use the code you used, OR use this with on your Windows prompt command (privilege access required): bcdedit /set {bootmgr} path \EFI\ubuntu\shimx64.efi

  3. some other reason like installing Ubuntu in UEFI mode with the pre-installed Windows in legacy mode, or another reason.

If you are still having problems, you might have a problem with the boot loader or even need to reinstall the whole system. This post was extremely helpful to me, so you might wanna check it out: Installing Ubuntu Alongside a Pre-Installed Windows with UEFI

0

Hey so I just wanted to add to this for anyone else that comes across the problem.

I have a laptop with windows 8.1 on it and I'm dual booting arch linux.

If you go back to the boot setup with f2, reenable safeboot and then add the boot loader file as a trusted source it will show up when you f12 in to the boot options screen. The file you are looking for is going to be a .efi file for me it was grub.efi which if I'm not mistaken is the same one ubuntu uses.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.