I've just removed acpi=off in updated Ubuntu 17.04 by Grub Customizer utility. And now I can't boot even with acpi=off parameter! I can see only white/orange dots on small rectangles in the center of the screen.

Also, I tried different kernels -, 33 (default) and 35 - with no success.

What can I do to fix it?

P.S. I'm using MSI X299 SLI motherboard. It has extremely buggy chipset X299 on board. But it worked perfectly fine with updated Ubuntu until I saved the new GRUB configuration.

  • if you only want to put it back the way it was; the easiest (assuming you're comfortable with tty/terminal) is to press <E> (edit) instead of <enter> at the grub screen. then add a " 1" (or " single") to the end of the "linux" line (so its forced to single-user or recovery-mode). it'll boot to text-terminal asking for password (always root for me; if you've not enabled root login it may be your username; I've never tried), where you cd;vim (or edit the file back to where it works; you're happy) then 'reboot'
    – guiverc
    Sep 23, 2017 at 8:47
  • But I can edit to where it was just by adding acpi=offafter pressing <E>. And it doesn't help! It's really wired.
    – Dmitry
    Sep 23, 2017 at 8:55

1 Answer 1

  1. Add acpi=off boot parameter.
  2. Press Ctrl+Alt+F1 after unsuccessful boot.
  3. Run sudo apt-get update and sudo apt-get upgrade commands.

Now I can boot but can't login. Also I can't use Ctrl+Alt+F1 anymore. Ubuntu is so buggy! Unbelievable.

  1. Select kernel 33 instead of 35 and it works again.

But what happened? It looks like I just restarted Ubuntu during update in background. And it just stopped to boot because I restarted it after launching Grub Customizer! It's not an operational system. It's garbage.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.