0

Four days ago, I simply shut down when in windows but when turned on the next time errors were coming either unable to find disk to boot or disk read error. I tried a Ubuntu live stick, but to my utter surprise both fdisk -lu & sfdisk -d gave the same output as below :-

    ubuntu@ubuntu:~$ sudo fdisk -lu /dev/sda
Disk /dev/sda: 238.5 GiB, 256060514304 bytes, 500118192 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x00000000

Device     Boot   Start       End   Sectors   Size Id Type
/dev/sda1          2048    923647    921600   450M  7 HPFS/NTFS/exFAT
/dev/sda2  *    1161216 352759807 351598592 167.7G  7 HPFS/NTFS/exFAT

The screenshot is of gparted and disk utility outputs where what used to be Ubuntu partition is showing up as free space !!! I believe I'll be able to recover Windows but haven't tried yet because first I want to recover Ubuntu which is more important to me ! Please help !

Testdisk repair and analyze don't help either. Rescue PFA as in the attached image parted was unable to find the partitions, was I supposed to do something else too besides that ! I am really feeling miserable after this & so many days have gone by ! I guess I should shift to Debian but am afraid from that too.

  • reinstall once again. – Mudit Kapil Sep 23 '17 at 5:00
  • Come on mate, clean install would overwrite everything ! – Nimk Sep 25 '17 at 8:16
  • I could not find Ubuntu partition on your disk.Recovery seems to be impossible. – Mudit Kapil Sep 25 '17 at 12:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.