I would like to update the repository of my system
holger@ubuntu:~$ cat /etc/os-release NAME="Ubuntu" VERSION="14.04.5 LTS, Trusty Tahr" holger@ubuntu:~$ uname -m i686
with a newer codelite version (9.1), as the offical ubuntu repository contains an old one (2.8). I followed these instructions: How to install the latest version of codelite?
But I see this dependency error:
The following packages have unmet dependencies: codelite : Depends: liblldb-3.6 but it is not installable Recommends: lldb (>= 3.4) but it is not installable Recommends: nodejs but it is not going to be installed E: Unable to correct problems, you have held broken packages.
The installed version is:
liblldb-3.9/trusty-security,now 1:3.9.1-4ubuntu3~14.04.2 i386 [installed]
I appreciate any ideas how to fix it.
Edit: By checking on the codelite dependencies, I see the following:
holger@ubuntu:~$ sudo apt-get build-dep codelite The following packages have unmet dependencies: libgtk2.0-dev : Depends: libglib2.0-dev (>= 2.27.3) but it is not going to be installed Depends: libgdk-pixbuf2.0-dev (>= 2.21.0) but it is not going to be installed Depends: libpango1.0-dev (>= 1.20) but it is not going to be installed Depends: libatk1.0-dev (>= 1.29.2) but it is not going to be installed Depends: libcairo2-dev (>= 1.6.4-6.1) but it is not going to be installed Depends: libxrandr-dev (>= 2:1.2.99) but it is not going to be installed E: Build-dependencies for codelite could not be satisfied.
libgtk2.0-dev depends on libglib2.0-dev and other libs. When I try to install libglib2.0-dev, I get the following error:
> holger@ubuntu:~$ sudo apt-get install libglib2.0-dev Reading package > lists... Done Building dependency tree Reading state information... > Done Some packages could not be installed. This may mean that you have > requested an impossible situation or if you are using the unstable > distribution that some required packages have not yet been created or > been moved out of Incoming. The following information may help to > resolve the situation: > > The following packages have unmet dependencies: libglib2.0-dev : > Depends: libglib2.0-0 (= 2.40.0-2) but 2.40.2-0ubuntu1 is to $ > Depends: libglib2.0-bin (= 2.40.0-2) but 2.40.2-0ubuntu1 is t$ > Depends: libpcre3-dev (>= 1:8.31) but it is not going to be i$ E: Unable to correct problems, you have held broken > packages.
So the dependend libs are on my system, they just differ in the minor release number. As I understand it I need version 2.40.0-2 for libglib2.0-0 but have version 2.40.2-0ubuntu1 installed.
What repo can I get these packages from? The standard repo only allows to install this version:
> holger@ubuntu:~$ apt search libglib2.0 > ... > libglib2.0-dev/trusty > 2.40.0-2 i386 Development files for the GLib library
Please let me know, what am I missing here?