1

I've finally managed to install Ubuntu in dual boot on my PC. Only problem is that I can't use my mouse, which is a Logitech G300.

Basically, the only things that work are the pointer and the scroll up/down. All clicks from all button just do nothing.

Every issue about this mouse seems to be about erratic behaviours of the buttons, or remapping them but I don't have any behaviour at all.

I've tried the methods in this thread but nothing works. I've also tried to use the command xinput test <id> to see what is going wrong and the results are quite surprising.

Basically, the mouse is listed twice in the xinput list : Once as a mouse, once as a keyboard. When I test the mouse side, clicking the buttons do nothing, as I would expect (Moving and scrolling do work though). Testing the keyboard side however, shows that the buttons events are registered, but fired as motion events I guess.

Since I'm back on Windows to write this question, I don't have the exact results but a left click would result in something like this :

motion[a]=1
motion[a]=0

I also checked the button mapping for both the mouse and keyboard device, and the mouse has a 1 to 24 mapping, whereas the keyboard has nothing.

Is there anything I can do ? I'm honestly all out of ideas and I don't really want to buy another mouse when this one works fine ...

Thanks

0

I have a Mouse with 3 buttons and I've configured them based on this thread.

You will have to install xev to determine the mouse buttons and clicks.

Sudo apt-get install xev

run it in a terminal

xev

it should prompt you a box figure point your mouse there and click your mouse from left click to right click as well as the buttons do this one at a time and take note of the button number(e.g left click = button = 1 )

then you can proceed to mapping by editing your xorg.conf(But make sure to have a backup first.

cp /etc/X11/xorg.conf /etc/X11/xorg.conf.old

vi /etc/X11/xorg.conf

Add this to the end of the line

Section "InputDevice"

Identifier  "Configured Mouse"

Driver      "mouse"

Option      "CorePointer"

Option      "Protocol"  "ExplorerPS/2"

Option      "ZAxisMapping"  "8 9"

Option      "Device"    "/dev/input/mice"

EndSection

Logout then login back again.

This is only an example of what I had where 8 and 9 are my buttons for forward and back mappings.

for more information I suggest you visit this link.

https://help.ubuntu.com/community/MouseCustomizations

Hope this helps.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.