5

I want to know How To make LXTerminal of lubuntu 16.04 transparent ?

3

First install "compton"

apt-get install compton

Then run the following command for testing:

compton --opacity-rule 45:'class_g *= "X-terminal-emulator"'

It's an opacity of 45%, change it to what you like.

Above I typed "X-terminal-emulator", but to get the string you have to type, do the following:
1.) type xprop enter
2.) now there should be a crosshair -> klick on your terminal
3.) search for "WM_CLASS(STRING)"
4.) use this in 'class_g *= '...'

You can copy a basic configuration from /usr/share/doc/compton/compton.sample.conf or here http://duncanlock.net/blog/2013/06/07/how-to-switch-to-compton-for-beautiful-tear-free-compositing-in-xfce/ into the file ~/.config/compton.conf (you must create this if not present)

To make this permanent you can put this command into your profile settings.

|improve this answer|||||
2

Open the LXTerminal and select Edit from the top menu and then Profile Preferences->Colors. From that screen you can change your terminal to transparent, partially transparent, the colors, etc.

|improve this answer|||||
  • can you please post the screenshots because I dont have this Profile Preferences->Colors – YaSh Chaudhary Sep 22 '17 at 16:37
  • I think that the settings of lxterminal only provide "fake" transparency. In other words, you'll see the root window and not necessarily the window immediately below the lxterminal window. It's possible that using something like compton maybe needed for true transparency. – DK Bose Sep 22 '17 at 16:56
  • @DKBose i've installed compton but issue still persists. – YaSh Chaudhary Sep 23 '17 at 4:18
  • @YaShChaudhary for me it was "rightklick" on the terminal window > then click "preferences" > then click on "background" > there you can set the "Opacity" but for me (using i3 window manager) that was no solution, because of mentiones "fake transparency" – eli Mar 29 '18 at 16:25
2

After installing compton (see eli's answer)

Edit your ~/.config/compton.conf file to include the following line:

opacity-rule = ["90:class_g *= 'X-terminal-emulator'"] 

This will make your terminal's opacity 90%.

Also add compton to your autostart for lubuntu in ~/.config/lxsession/Lubuntu/autostart

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.