My sound works just fine in 11.10 64-bit install on HP dm1-4050 Sandy Bridge notebook (e.g. audio works in Banshee, flash, games, browser, Thunderbird email notification, etc.), but the core desktop notifications (e.g. pressing a tab in a terminal where there is more than one option should trigger a terminal bell, or changing volume using volume keys should be accompanied with the supporting "quack" that the volume app makes) do not work. I've intentionally disabled login sound as explained here on ask ubuntu but even enabling it back makes no difference. These notifications did work before just fine and I am not sure when did the actually stop working but it must've been fairly recently.

Only things I did were trying to install some ppa edge xorg drivers for my intel card (a separate issue) but also reverted them all with ppa-purge once I discovered they did not improve anything. Other thing I did was check volume settings with alsamixer and did alsactl store for the soundcard after I did some experimenting with volume settings for PCM (on my laptop PCM at 100% crackles so I had to lower it and make pulseaudio ignore its setting as per ask ubuntu's page). That said, neither of these should have any bearing on the said notifications since the volume is up and they clearly work everywhere else but the core desktop events. The system ready drum sound when Ubuntu boots and user reaches the login screen also does not work.

The guest login behaves exactly same as mine. Audio works (including the login sound since I've not disabled it for the guest account), but no quacks when changing the volume or terminal bell sounds...

I've tried copying ubuntu sounds to /usr/share/sounds/ as suggested on ask ubuntu and that did not work. I also tried using dconf-editor to check sound theme settings and tried both freedesktop (which is what it was set to) and ubuntu, as suggested on ask ubuntu. This did not work either. I tried purging the ~/.pulse folder and the /tmp/*pulse* entries, rebooting and restarting pulseaudio with -D flag. While audio came back on and behaved just fine in all aspects (e.g. one can adjust volume levels, play music, games, in-browser sound stuff, and other app alerts) except for the system ready drum sound (at the login screen), and any system event (terminal bell and volume change quack sound). It is interesting that the quack sound works inside system settings->sound when adjusting levels there, but it does not when volume is changed via top bar's volume settings... I do recall that at one point yesterday when I was restarting pulseaudio the quacks that accompany volume change did start working but I have no idea what caused that. This was also when I first realized those alerts were not working. After rebooting it was again gone.

I did compile my own 3.0.14-rt31 kernel a little while ago as instructed on one of the wiki's for the 11.10 rt kernel. Everything works as before except for the said sound alerts. I am not sure if this began happening since I started using the rt kernel though and yesterday's momentary ability to hear those quacks while changing the volume make me believe that the kernel is not one responsible for this problem.

One more thing I can think of is that I used alsoft-conf tool to configure buffering on the OpenAL (due to TA Spring's choppy audio) and changed in there default audio device to ALSA. I also tried reverting it to Pulseaudio as the only allowed output but the bottom part of the Backend tab always reverts to ALSA even when I select Pulseaudio. The pulseaudio does remain as the only active choice on top. This, however, once again does not make any sense in terms of preventing desktop audio alerts when everything else including OpenAL games plays sound just fine...

So, there you have it, as verbose as I could make it :-). I tried all I could find on this issue and had no luck so far... Any ideas?

  • At this point I am also wondering if anyone else even has either terminal bell or volume quack sound (when volume is changed via applet) working in 11.10? Jan 16, 2012 at 7:02
  • FPickle, please add the solution with "Post Your Answer" if you've solved the issue. It's an important part of how the site works, and will earn you "rep".
    – Jjed
    Mar 16, 2012 at 6:04
  • Jacob, are you saying you can earn rep by posting some bogus answer to your own question, then marking it as solved? If that's true, it sounds like a defect in Stack Exchange. Kinda like eBay sellers upping their rep by selling hot air back and forth to friends. Anyway, he needs to explain how his "solution" fits in with what I confirmed with a single kernel but different window managers. Mar 20, 2012 at 19:15

2 Answers 2


This is not a sound problem; the event is getting lost, as can be seen in the system settings => universal access => hearing tab. Setting it to visual alerts also does not work.

I found that all of this works as expected using metacity (run metacity --replace), but then stops working when you go back to Compiz (run compiz --replace).

Note: I did this in Gnome compatibility mode. In compiz, it seems that metacity doesn't run, although everything else keeps running, and with a terminal, you can get back to compiz/unity from the terminal. Note, though, that the terminal bell will work in this mode.

  • Actually, this does not have to do with the metacity vs. compiz but as I just learned earlier today, it has to do with the kernel itself. The said system was running linux-rt kernel which is apparently missing some of the Ubuntu tweaks that allow this. Reverting to linux-lowlatency fixed this (which makes sense since rt kernel is not supported while lowlatency practically offers the same performance)... Hope this helps! Mar 16, 2012 at 5:51
  • So why is it that simply switching between compiz and metacity, without changing the kernel, makes it either work or not? Same kernel, not even logging out: Metacity - works; Compiz - doesn't work. You sound like you understand the issue, but you did not do a very good job of addressing this discrepancy - care to elaborate? Mar 16, 2012 at 16:08
  • You are absolutely right. Your solution may be also correct (I haven't tried it). I think they are two different approaches to the same problem. One suggests that there is a core bug, and another suggests that the same core bug has been fixed upstream (at least that is the case so far). That said, your answer IMO does not provide solution for those interested in using Unity (for that matter, neither does mine as it requires a new, beta version of Ubuntu). Perhaps it might be a good idea to file for a bug report? Mar 22, 2012 at 3:44
  • 1
    Actually, I entered this as a bug report a few months ago in Compiz's bugzilla (bug #70), but I don't know that anyone pays attention. Note that I didn't intend my answer to be a solution; I was identifying the problem, and trying to notify the developers, but I don't know if there is an actual solution. Mar 23, 2012 at 4:38

A potential explanation is what I mentioned above (with some edits in the light of new developments), namely:

This problem may have been fixed in the 12.04 release, at least partially (the volume quacks are there but terminal bell isn't). The said, the kernel may also play a part in this. The system I was originally running linux-rt kernel which is apparently missing some of the Ubuntu tweaks that allow this. Reverting to linux-lowlatency fixed this (which makes sense since rt kernel is not supported while lowlatency practically offers the same performance)... Hope this helps!

That said, I do have now a situation where volume adjustments do sound out but the terminal bell doesn't. This is on a 12.04 beta and things are changing on a daily basis, so that may be a part of it as well...

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .