This question already has an answer here:

I just completed a new PC build, and installed Ubuntu 17.04.

The first thing I did was try to download Google Chrome, and lo and behold, the install button doesn't work.

I have seen this bug elsewhere, but I didn't really get the fix. (I have no idea how to work Ubuntu besides being spoon-fed tutorials.)

I also tried to download the Minecraft launcher, and there are many different solutions, most using a PPA. None of them worked. One of them had an install link in the software tab of Ubuntu, and I had the same glitch as with chrome. This is really troubling me and I need some help! Thanks!

marked as duplicate by Panther, Eliah Kagan, Zanna, David Foerster, Eric Carvalho Sep 23 '17 at 11:58

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • I suggest a better title. It sounds as if you can download without any problem. Why are you downloading .deb rather than using the ubuntu repositories ? I highly suggest chromium rather than chrome unless there is some feature you need in chrome that is lacking in chromium (very unlikely). – Panther Sep 22 '17 at 13:26
  • See also askubuntu.com/questions/307280/… – Panther Sep 22 '17 at 13:27
  • Chrome requires libappindicator1 – Android Dev Sep 22 '17 at 13:41
  • See this: askubuntu.com/questions/957540/… – pomsky Sep 22 '17 at 13:56