0

I had LinuxMint + Windows 10 in dual boot, everything was working fine.

For some reason, I installed Kubuntu instead of LinuxMint, everything went smoothly. When starting my laptop for the last weeks, the grub let me choose between Ubuntu and Windows.

I'm used to start automatically Ubuntu OS, and it worked fine. But I recently tried to start windows OS, and it wasn't working anymore : it comes back to grub when I select the windows boot.

So I started a live-ubuntu session, installed and run boot repair, you can find 1st Log here http://paste.ubuntu.com/25591401/

I tried to run Recomended repair, and I get this message "GPT detected. Please create a BIOS-Boot partition (>1MB, unformatted filesystem, bios_grub flag). This can be performed via tools such as Gparted. Then try again."

I did what I was told to do, (creating a Bios-Boot partition unformatted bios_grub flag with gparted) then I tried again to run Boot repair and the option Recommended repair, I followed instructions and it finished with an error message and this 2nd log : http://paste.ubuntu.com/25591550/

I reboot my laptop (without usb live) : the Grub does not start but (tadam!!!) it is Windows 10 wich is starting automatically. I cannot have a booting choice anymore.

I would like to get (back) my working Grub when I start my computer. Anybody has an idea?

Thanks for helping. Tell me if you need more info.


Thank you very much Rod for your help and concern.

I follow your instructions, and from How to change ubuntu install from legacy to uefi , I used the method 1. At the end (when it gives the pasteubuntu link for the logfile which is http://paste.ubuntu.com/25594817/ ), and it was written "an error occured".

When the laptop is booting, I can see very quickly (only appears a sec) something like "Failed to open EFI/grub... not found" and "Fail to load image...??"

What do I miss? It seems the new grub is not installing correctly?

PS : I wanted to try the method 2 with your refind utiliy. I copied it on a FAT32 (boot flaged) USB flash drive, but when I try to boot from it, no success. I probably miss something cause I'm really tired. I'll try smthg else and dig more of it tomorrow.


I tried the second method (with refind) and I still have the same issue. Booting from an usb with refind allow me to choose between .

  • Boot Microsoft EFI boot from EFIPART
  • Boot EFI/Boot/bkpbootx64.efi from EFIPART
  • Boot EFI\ubuntu\grubx64.efi from EFIPART
  • Boot EFI\refind\refind_x64.efi from EFIPART
  • Boot Fallback boot loader from EFIPART
  • Boot boot\vmlinuz-4.4.0.... signed from racine

I choose the last one and Kubunut started. then I install refind via line commands. I reboot the computer. I still have a quick message "Failed to load ...EFI...GRUB" appears at the beggining, then the laptop starts windows directly.

I suppose that I don't put the correct object (EFI booting shit) at the correct spot. I suppose also the sda9 I created is useless, but I'm not sure of it. I suppose I have toooooooo many options for starting my computer.

  • I am glad you got windows working again. In many modern UFI (bios) you select which OS to boot using some sort of menu . For example on my laptop I hit F9 during boot and I get a menu asking which OS to boot. – Panther Sep 22 '17 at 12:59
  • 1
    Boot-Repair had a bug which is now fixed where it was suggesting the bios_grub even for UEFI boot systems. You need to run the newest Boot-Repair and in advanced mode do the full uninstall/reinstall of grub2. You want the UEFI version grub-efi-amd64, not BIOS version grub-pc. Also grub only boots working Windows, or Windows that is not hibernated. And Windows updates will turn fast start or hibernation back on and probably runs in back ground. But then you boot Windows from UEFI directly and turn fast start back off. Then grub will work to boot Windows. – oldfred Sep 22 '17 at 14:47
  • @oldfred, FWIW, I just tried running a BIOS-mode Boot Repair on an EFI-mode installation. It did not ask for a BIOS Boot Partition, it claimed to fix the system, but it didn't boot in BIOS mode. Thus, it may be that Boot Repair has traded a poorly-worded prompt for a complete lack of helpful feedback on this issue. OTOH, maybe I missed something in my test, or maybe something about my test installation was odd. (It was in a VirtualBox VM that I use for testing rEFInd.) – Rod Smith Sep 22 '17 at 19:19
  • It may be already fixed. bugs.launchpad.net/boot-repair/+bug/1718808 Yann on update to bug said this: Should be fixed from 4ppa44. – oldfred Sep 22 '17 at 20:27
1

What Happened

I'll begin by addressing the question of what got you to the point where you are now. There are several steps and mistakes made along the way....

  1. Your computer was working correctly with a properly-configured EFI-mode dual-boot setup. Note the EFI-mode part; that's critical.
  2. For some unknown reason, Windows stopped booting. This could have been a GRUB configuration error, damage to a Windows boot file, or some other issue. My suspicion is a GRUB problem, but it's unclear to me precisely what the cause was.
  3. You booted an Ubuntu live CD in BIOS/CSM/legacy mode. This is critical; compare to point #1. Booting in this mode was a mistake, but it was easily corrected at this point by booting in EFI mode, if you'd caught it.
  4. You ran Boot Repair from this BIOS-mode boot and it complained about the lack of a BIOS Boot Partition. (IMHO, this warning should be rephrased because it's leading increasing numbers of people astray.)
  5. You created the BIOS Boot Partition that Boot Repair requested. This was a mistake, but still not a critical one; the mere presence of a BIOS Boot Partition is not particularly damaging.
  6. You re-ran Boot Repair, which installed a BIOS-mode version of GRUB. This was a mistake, and it was a damaging one; this step altered the boot loader configuration on the computer in a way that would make it impossible to boot in the way you'd been booting before, at least without making further changes.

The end result is an installation that has Ubuntu installed in BIOS mode and Windows in EFI mode. To switch boot modes, you must use a boot manager that can do this mode-switching. GRUB cannot do it, but most EFIs have built-in boot managers that can do the job. These are usually awkward to use, though. My rEFInd boot manager can do the mode-switching, but it can also boot Ubuntu in EFI mode, so if you install rEFInd, you can simply bypass the BIOS-mode GRUB. Re-installing the EFI-mode GRUB is another option.

What To Do Now

In principle, you should be able to use the computer's built-in boot manager (usually accessed by hitting a high-numbered function key, or sometimes Esc or something else, early in the boot process). In practice, you'll probably be better off by restoring GRUB to more-or-less its original configuration or by installing another boot manager. Answers to the below two questions go into detail on how to do this:

Note that this still leaves the question of why Windows stopped booting. As it's booting now, my suspicion is that your GRUB configuration became subtly damaged. Perhaps a GRUB update went wrong. GRUB can be quite delicate that way. Judging by posts, rEFInd seems to be a little more reliable, with the caveat that if Secure Boot is active, you'll have to jump through extra hoops to get it working. In any event, I'd set aside this question for the moment; instead, apply a fix and, if Windows stops booting, post a new question about that problem.

For more background reading, I suggest my page on the Compatibility Support Module (CSM). This is an EFI feature that provides BIOS boot support. Most modern PCs have a CSM, but it's usually shipped in a disabled state. Many sites provide the poor advice to enable the CSM prior to installing Ubuntu. When dual-booting with an EFI-mode Windows, the CSM is seldom required, and enabling it often leads to the sort of problem you're having. I'll shed no tears when the CSM rides into the sunset....

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.