I'm really looking forward to 17.10 with Gnome and other new features. One key feature from previous versions of Ubuntu is fractional scaling where I found a value of 1.25 to be perfect (14", 2680x1440).

Gnome 3.26 is supposed to support fractional scaling but I haven't found this in the settings of the 17.10 beta. I can only choose between 100% (too small for me) and 200% (way too big...).

Will Ubuntu 17.10 with Gnome 3.26 support fractional scaling?

Best regards,

Håkan

closed as off-topic by mikewhatever, karel, heynnema, Pilot6, Eric Carvalho Sep 23 '17 at 11:58

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Bug reports and problems specific to development version of Ubuntu should be reported on Launchpad so that developers can see, track and fix these issues." – mikewhatever, karel, heynnema, Pilot6, Eric Carvalho
If this question can be reworded to fit the rules in the help center, please edit the question.

According to one recent OMG! Ubuntu! article

Despite the best efforts of many fractional scaling wasn’t ready for the GNOME 3.26 release earlier this month.

As it is now finalised that Ubuntu 17.10 is going to have GNOME shell v3.26 most probably fractional scaling won't be included in Ubuntu 17.10.

But the same article provides a workaround to enable experimental fractional scaling in GNOME 3.26, although it works only in the Wayland session. Apparently it can be activated by running the following command

gsettings set org.gnome.mutter experimental-features "['scale-monitor-framebuffer']"

Then you should see a number of extra scaling options in the Scale section of Settings > Devices > Displays.
enter image description here
(Screenshot from the same article)

  • But how to obtain per display fractional scaling? Where to set DPI for monitor 1 to eg. 150% and monitor 2 to 125% ? – JohnDoe Oct 3 '17 at 18:43
  • What is a "Wayland session?" – Raffi Khatchadourian Nov 6 '17 at 20:32
  • @RaffiKhatchadourian en.wikipedia.org/wiki/Wayland_(display_server_protocol) Wayland replaced Xorg as the default session in Ubuntu 17.10 (but you can still switch to Xorg if you wish) – pomsky Nov 6 '17 at 20:34
  • @pomsky Ah, I just upgraded and I think my default session is Xorg. How do I switch to Wayland? – Raffi Khatchadourian Nov 6 '17 at 20:39
  • 2
    @RaffiKhatchadourian askubuntu.com/questions/961304/… If Wayland is not available, then most probably it's disabled by your hardware (Nvidia is not working nicely). – pomsky Nov 6 '17 at 20:40

Not the answer you're looking for? Browse other questions tagged or ask your own question.