0

On my machine I have two monitors on DVI, and two monitors on DisplayPort using MST and a DP hub. Previously, I only had one monitor on DP, and it allowed me to select that monitor as an audio output device.

Now that I have the two monitors, the hub, and MST running, I can no longer select the DP monitors for audio output. The default "sound" hardware settings don't recognise that it exists, and pavucontrol knows something should be there, but thinks that it's HDMI, and also unplugged.

In windows, the monitor can still be used as an audio device, but in Ubuntu it's lost that ability. Video works fine on all 4 monitors, just no sound from the monitor speakers.

e: Graphics card is a NVidia GeForce GTX 670, and NVidia driver is 375.82

  • Graphics card?... – user692175 Sep 22 '17 at 3:17
  • NVidia GeForce GTX 670. Getting a little old now, but still does the job. – samlev Sep 22 '17 at 4:28
  • It should do a lot of jobs :) but for this particular issue you probably need to install Nvidia proprietary drivers. – user692175 Sep 22 '17 at 4:33
  • I'm running them already, otherwise the MST wouldn't work at all. I found that out the hard way. Updated post with card and driver version. – samlev Sep 22 '17 at 5:15
  • 1
    Thank you for the update. Unfortunately I'm out of ideas. – user692175 Sep 22 '17 at 5:23

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.