1

I was changing my administration password to my computer and I must have made a mistake and mis-typed some part of the password because I tried every password I had put on the PC, nothing worked. Is there anyway to wipe the PC (the memory card is a SSD Sandisk 120GB) or recover the administration password? Plus the PC is currently turned off so is there a way I turn It on in a passwordless root or something? Also every time I try the grub boot, when it asks me for a new password I enter it and it says "authentication token manipulation error. What does that mean???? Will I have to wipe the memory or just buy a new one.

  • There's no "admin" password in Ubuntu. The first user created in the installation is the "admin" and the password is the same. – user692175 Sep 21 '17 at 21:04
  • You can't recover the admin password, but you can establish a new password. At the moment I do not remember how it is done. You may want to start here: askubuntu.com/questions/423942/… – Steve R. Sep 21 '17 at 21:05
  • I think you are mistaken a user password with a grub password? – Ziazis Sep 22 '17 at 8:18
4

The official wiki:

I tried this with a wireless keyboard and it did not work. My guess is that I would have to connect a non-wireless one so you might have that issue. As an alternative, the Wiki has a link to the LiveCD Recovery here:

The true administrator (superuser) of any unix system is called "root". On most Linux systems these days, the root user is locked out preventing someone running as root from destroying the system inadvertently or by default allowing some malware or evil user access to the system. Instead, a user is given the right to become the administrator when running programs if and when that user supplies a password to execute a command that only root can. If you "lose" that password, that is the password you need to reset to something else, not root's password. Root can set any user's password so you need to boot to the point that a root shell can be started (without entering a password) then set the password of your user login name to whatever you want. The error message occurs here:

There is a "Authentication Token Manipulation Error" when trying to update user's password in Ubuntu. The reason why passwd failed is that filesystem was mounted as read only, which prevents changing the password. A way to fix this issue is to remount filesystem and then to check permissions of /etc/shadow file.

If you read those instructions I gave you, it tells you how to remount the file system so you can write to it. If you have booted your system to the point where you have a root shell, see instruction 8:

The root partition is mounted read-only. To mount it read/write, enter the command

mount -o remount,rw /

With the system mounted rw, you should not get that error.

  • I have a wired keyboard and I believe the Administrator password has more security than the normal user password. – 4happyP Sep 21 '17 at 22:09
  • but then again, the first password is just called the administration password so it's probably just labels that concern me. – 4happyP Sep 21 '17 at 22:38

Not the answer you're looking for? Browse other questions tagged or ask your own question.