This question already has an answer here:

Ubuntu-server 17.04 x64, Cinammon 3.2.7, Kernel 4.13.3 generic.

Attempting to set up VirtualBox, though so far I have been unable to start any virtual machine. Upon installation (apt install virtualbox), I get the following lines near the end of the installation process:

● virtualbox.service - LSB: VirtualBox Linux kernel module
Loaded: loaded (/etc/init.d/virtualbox; generated; vendor preset: enabled)
Active: failed (Result: exit-code) since Thu 2017-09-21 19:57:07 +04; 18ms ago
Docs: man:systemd-sysv-generator(8)
Process: 463 ExecStart=/etc/init.d/virtualbox start (code=exited, status=1/FAILURE)
CPU: 28ms

Sep 21 19:57:06 Hiigaran systemd[1]: Starting LSB: VirtualBox Linux kernel module...
Sep 21 19:57:06 Hiigaran virtualbox[463]:  * Loading VirtualBox kernel modules...
Sep 21 19:57:07 Hiigaran virtualbox[463]:  * No suitable module for running kernel found
Sep 21 19:57:07 Hiigaran virtualbox[463]:    ...fail!
Sep 21 19:57:07 Hiigaran systemd[1]: virtualbox.service: Control process exited, code=exited status=1
Sep 21 19:57:07 Hiigaran systemd[1]: Failed to start LSB: VirtualBox Linux kernel module.
Sep 21 19:57:07 Hiigaran systemd[1]: virtualbox.service: Unit entered failed state.
Sep 21 19:57:07 Hiigaran systemd[1]: virtualbox.service: Failed with result 'exit-code'.

Tried following the top answer in this question, by removing virtualbox-dkms and installing it again. This resulted in the same lines as above.

Attempting to start a virtual macine, I get an error giving the following details:

Kernel driver not installed (rc=-1908)

The VirtualBox Linux kernel driver (vboxdrv) is either not loaded or there is a permission problem with /dev/vboxdrv. Please reinstall virtualbox-dkms package and load the kernel module by executing

'modprobe vboxdrv'

as root.

where: suplibOsInit what: 3 VERR_VM_DRIVER_NOT_INSTALLED (-1908) - The support driver is not installed. On linux, open returned ENOENT. 

The modprobe command results in:

modprobe: FATAL: Module vboxdrv not found in directory /lib/modules/4.13.3-041303-generic

marked as duplicate by Eric Carvalho, Zanna, Yaron, Mark Kirby, Charles Green Oct 4 '17 at 14:29

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • ...and how did ubuntu server get kernel 4.13 and Cinnamon? Shouldn't it be kernel 4.10, and guiless? – mikewhatever Sep 21 '17 at 16:29
  • Installed server variant to cut down on bloatware. UKUU to update kernel, apt installed the desktop. – Hiigaran Sep 21 '17 at 16:53
  • 1
    "Installed server variant to cut down on bloatware. UKUU to update kernel, apt installed the desktop." Oh dear, I don't know why you did it, does it make any sense to you? Anyway, 4.13 is probably too new, and glitches like this one should be expected. I doubt you need to do anything other then wait for a few weeks. I'll vote to close this, as this is not about Ubuntu. – mikewhatever Sep 21 '17 at 17:13
  • Ah, so a question about getting Ubuntu software to work on Ubuntu is not about Ubuntu and doesn't belong on the site that helps with issues on Ubuntu. Got it. – Hiigaran Sep 21 '17 at 18:00
  • The problem seems to be not with "Ubuntu software", but with the user modifications, primarily with the new mainline kernel you've installed. Had it happened with the default kernel, the question would have been on topic. Anyway, the same problem is easily found with suggested solutions. Here, I've googled it for you: askubuntu.com/questions/947011/…. – mikewhatever Sep 21 '17 at 18:47

Solution seems to be to not install the virtualbox package that comes with Ubuntu. Following the steps to add a 3rd party repository as shown here, then installing the virtualbox-5.1 package appears to get things working with no further actions required.

  • This worked for me on Ubuntu 16.04. On 14.04 it failed, but the standard sudo apt-get install virtualbox worked fine. – lps Jul 12 '18 at 7:29

Not the answer you're looking for? Browse other questions tagged or ask your own question.