0

I'm facing some issues with my USB hard drive and VirtualBox. The problem is that it's detected in devices list and I activate the checkbox to capture the device but it's not captured by the guest system (Windows 7). The only way I made it work was adding a filter in virtual machine configuration and when the system starts the device is captured but I don't want this behaviour because when I unplug the device and then plug it again, the same problem occurs, it won't recognize it again until I restart the virtual machine.

Suggestions? Thanks in advance.

  • Are you in the vboxusers group in the host OS? – George Udosen Sep 21 '17 at 16:01
  • @George Yes, my user is invboxusers. When I first installed Virtual Box I couldn't see any devices and after adding my user to vboxusers all devices were listed. Now that all devices are listed, I'm trying to capture them in the guest machine. – ProtectedVoid Sep 21 '17 at 16:09
  • @George My host system is Linux. I think I can't apply that solution. – ProtectedVoid Sep 21 '17 at 16:20
  • OK sorry to hear that. – George Udosen Sep 21 '17 at 16:22
0

You need to have the latest virtual box installed.

Other things to check

  • reboot once the virtual box is installed
  • also install Oracle VM VirtualBox Extension Pack which is same as your installed version
  • check usb 2.0 as an usb filter (usb 3.0 might not work properly)
  • add yourself as part of virtual box user .command "sudo usermod -a -G vboxusers [user_name]"
  • install virtual box additional pack which can be activated by Device > Insert Additional CD image.
  • I will make sure that I've tested all these recommendations. Thank you. – ProtectedVoid Sep 21 '17 at 16:38
  • I checked all of them, but still not working. – ProtectedVoid Sep 21 '17 at 17:11
  • what is your virtual box version ? and most important what is your kernel version ? – SIDDHARTH Sep 22 '17 at 3:30
0

I've found an alternative, not a solution itself, that would work for all external storage devices. You can set up a shared folder that points to your external device root, checking "auto mount" option so it mounts automatically in guest machine when it starts. Your device will be displayed in guest machine as a "network device", at least in Windows (being guest).

I find that this alternative has a big pro: You can interact with your device contents in both systems, host and guest and contents will be automatically updated. Capturing a device in your guest machine will block the device for exclusive use, that could be a disadvantage.

  • that would great too using samba to mount all the partition to both the areas. But it`s only for storage and nothing else. With my recommendation he can use any usb storage he connects to the host system avilable to the virtual too. – SIDDHARTH Sep 21 '17 at 16:54

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.