1

Linux newbie here I've tried to install Ubuntu 17.04 but it crashed and show this message dialog " the 'grub-efi-amd64-signed' package failed to install into /target/. Without the GRUB boot loader, the installed system will not boot. "

This is my boot-info link http://paste.ubuntu.com/25585644/

Then i try to repair it using boot-repair and follow the instruction until it finish(im not sure i've done it correctly). next, i can boot ubuntu but crash report show up "sorry, a problem occured while installing software. Package :grub-efi-amd64-signed 1.80.2+2.02~beta3-4ubuntu2.2"

Is there any correlation with forcing uefi installation?

Thanks for your help

  • If you can boot into ubuntu , boot-repair is finished. To see what is causing your current error open a terminal the enter sudo apt-get update && sudo apt-get upgrade and post any error messages. – Panther Sep 21 '17 at 15:21
  • Same shit happen when I try to install Ubuntu Budgie 18.04 on hd(0,1) as a secondary system. First one is Debian 9 on hd(0,0) where Grub (from Debian install) is installed. When Ubuntu's install crashes during new Grub installation I can't get mount new btrfs partitions (I get two folders with @ and @home names) – Marecky Jul 28 '18 at 21:51
0

Probably your system hasn't been configured to boot UEFI files while your installation medium is UEFI enabled. That's why you're getting the error. You can configure your system to allow UEFI by going into your BIOS and turning off fast boot or Secure boot. I believe this should work as it worked for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.