1

I had ubuntu14.04LTS running and installed ubuntu 17.04 making a partition. So I got 2 choices at startup. This worked fine until a couple of weeks. I assume after a 14.04 update, the initial menu (grub?) disapeared, and notebook starts directly on 14.04.

I tryed boot-repair with this result: GPT detected. Please create a BIOS-Boot partition (>1MB, unformatted filesystem, bios_grub flag). This can be performed via tools such as Gparted. Then try again. Alternatively, you can retry after activating the [Separate /boot/efi partition:] option.

Things from there are too complicated in forums, I am not an expert, just a user.

Partitions are still there with all the content.

bootinfo from boot-repair: http://paste.ubuntu.com/25575784/

Hope someone can help. Thanks.

  • You have installed in UEFI mode (correct) but booted Boot Repair in Legacy (incorrect twice, Boot Repair isn't even for this cases). Now: 1. You can boot either from the UEFI boot settings, probably, or 2. Just do sudo update-grub and it should find both again and recreate the boot entries (if you prefer 17.04's Grub to be in charge, then boot it and do the same). – user692175 Sep 21 '17 at 3:35
  • You have an UEFI system with UEFI installs. But if Boot-Repair is asking for a bios_grub partition then you must have booted the Ubuntu live installer in BIOS mode as that would then want to install a BIOS boot version of grub. Only boot system & any live installer in UEFI mode. Many with Secure Boot have to specifically allow USB boot in UEFI as that is not considered "Secure". Probably easiest to boot in UEFI mode, add Boot-Repair and in advanced mode do the total reinstall of grub. – oldfred Sep 21 '17 at 3:36
  • @MichaelBay I did sudo update-grub, many lines about found things, but still boots directly to 14.04 – Matías Fernández Sep 21 '17 at 22:49
  • @oldfred I think I am in UEFI mode now, how can I check that without going to BIOS menu? and boot-repair gives me this "GPT detected. Please create a BIOS-Boot partition" message – Matías Fernández Sep 21 '17 at 22:53
  • @oldfred recent bootinfo paste.ubuntu.com/25589056 – Matías Fernández Sep 21 '17 at 22:59
1

Your grub.cfg should be this:

cat /boot/efi/EFI/ubuntu/grub.cfg
search.fs_uuid 94ce33db-7654-4e3e-a9be-a3063bb155cf root hd0,gpt4 
set prefix=($root)'/boot/grub'
configfile $prefix/grub.cfg

You get UUID from this(I got it from the Boot-Repair report).

sudo blkid -c /dev/null -o list

And you want to change first line to UUID of sda4 & gpt4 to gpt6, copy & paste UUID from above command. Orcopy this line & paste. Best to also add # to existing line as first char changing to a comment. Then easier to revert if required.

search.fs_uuid 00aee336-b9ae-4c75-8edc-a19adb0b5451  root hd0,gpt6

sudo nano /boot/efi/EFI/ubuntu/grub.cfg

It should end up like this:

search.fs_uuid 00aee336-b9ae-4c75-8edc-a19adb0b5451  root hd0,gpt6
#search.fs_uuid 94ce33db-7654-4e3e-a9be-a3063bb155cf root hd0,gpt4 
set prefix=($root)'/boot/grub'
configfile $prefix/grub.cfg
  • how do you copy and paste here terminal lines in their original format? – Matías Fernández Sep 22 '17 at 11:09
  • 4 spaces make a command & one of the icons will make multiple lines as commands by indenting them the 4 spaces. – oldfred Sep 22 '17 at 14:40
  • Ok. I will study the procedure and try. Not a simple thing to me. – Matías Fernández Sep 23 '17 at 2:10
  • should just be a copy & paste. nano is old style editor, you have to use arrow keys to move pointer, but still can copy & paste. – oldfred Sep 23 '17 at 3:50
  • SOLVED !!!! Thank you @oldfred... if you can, tell me what whe did.... – Matías Fernández Sep 25 '17 at 0:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.