2

This question is an exact duplicate of:

I'm attempting to install the drivers for my Nvidia GPU by following the steps listed here, but after launching the installer it informs me that I must disable the Nouveau kernel driver before installation can continue (There is also an error message displayed before this stating that the 'distribution-provided pre-install script failed', but from what I've read in other posts it shouldn't be a problem to just continue and ignore it?).

Anyway, I've followed the steps listed here in an attempt to disable the Nouveau driver with no such luck. I've run sudoedit /etc/modprobe.d/nvidia-graphics-drivers.conf and populated the file with the given data and saved it, I've edited a line within the /etc/default/grub file so that it now reads GRUB_CMDLINE_LINUX_DEFAULT="nouveau.blacklist=1 nomodset quiet splash", and I've attempted to install the driver from within tty1 by first disabling gdm3 using sudo service gdm3 stop and then using the command sudo sh NVIDIA-Linux-x86_64-384.69.run. Even after doing all this the same error informing me that Nouveau needs to be disabled appears.

I should mention at this point that I used this method of installing the driver once before a few days ago and it worked. For the life of me I can't remember how I got it to work or why it won't work this time around. Also this is essentially a completely fresh install of Ubuntu Gnome 16.04 LTS, the only alterations I've made so far are the installation of Chromium, Discord, a couple of extensions and I've made a few UI changes in the Tweak tool.

So, can anyone offer any more advice on how to disable Nouveau? I feel that if I can get this disabled entirely then I'll be able to install the driver without further issue, but until I can figure this out I can't currently continue using my system because the default Nouveau driver causes the UI to freeze without reason or warning sporadically. In fact it crashed while I was typing this out, lucky for me Chromium saved what I'd written.

Thanks in advance for any help and advice!

marked as duplicate by Pilot6, Charles Green, waltinator, Eric Carvalho, storm Sep 23 '17 at 12:50

This question was marked as an exact duplicate of an existing question.

  • You have a much easier and safer way of installing the same driver version by adding the graphical drivers PPA. No need to disable nouveau either – user692175 Sep 20 '17 at 17:58
  • I've attempted to install the drivers using the ppa, but that presents itself with its own issues. – Meta Sep 20 '17 at 18:26
  • I've posted this as a separate question as this is directly related to disabling Nouveau, whereas my other post is asking how else to install the drivers. – Meta Sep 20 '17 at 18:27
  • 1
    It is a bad idea to install driver this way. It is a typical XY problem The drivers should be installed from repos or a PPA. If you have problems with that, you won't solve them by blacklisting nouveau. It will make things worse. – Pilot6 Sep 20 '17 at 18:36
  • @Pilot6 - I've attempted several times to install the drivers via the PPA, but each time I'm faced with the issue of not being able to see the login page, let alone login in the first place. The tty's all forcefully back me out every few seconds, meaning it takes twice as long to type anything at all, and the only way to fix this is to purge all nvidia drivers and reboot, leaving me back at square one? Plus as I stated in my post I used the method explained once before and it worked perfectly. The drivers were listed as manually installed, but other than that it was exactly what I wanted? – Meta Sep 20 '17 at 18:44
3
  1. ctrl+alt+f1
  2. Login
  3. sudo service lightdm stop
  4. sudo modprobe -r nouveau
  5. sudo service lightdm start
  • I'll try this and see how it goes. Thanks for the suggestion. – Meta Sep 20 '17 at 18:27
  • This did not work for me. Still get nouveau in my lsmod after re-logging in. – Hendy Apr 29 '18 at 6:13
3

Based on the first link, I am assuming you are using the run file. I recently went through a similar process with my own computer (14.04). According to the instructions from Nvidia, you do the following to disable the nouveau drivers. Note that this does not require any changes to Grub or LightDM.

  1. Create /etc/modprobe.d/blacklist-nouveau.conf with the content:

    blacklist nouveau
    
  2. Run: sudo update-initramfs -u

  • I'll give that a go and see if it works for me too. Thanks for the suggestion. =) – Meta Sep 20 '17 at 18:36
  • 2
    Wnat is the point of simultaneously blacklisting nouveau nad setting options for it? – Pilot6 Sep 20 '17 at 18:36
  • @Pilot6 You are blacklisting it using the file you create. What I have listed below the first point is the contents of that file. This process is independent of everything else that Meta has already tried. Based on the instructions from Nvidia, the changes to lightdm, grub, and the other file are all not needed. Whether or not they are alternative I cannot say. All I know is that this worked for me without any issues. – Andrew Shum Sep 20 '17 at 18:39
  • 1
    This setting is wrong. One of the lines may be ignored. But it is still wrong. – Pilot6 Sep 20 '17 at 18:40
  • 2
    @AndrewShum: because it is blacklisted, hence it worked. The setting modeset=0 is for kernel mode setting (kms) is redundant. modeset=0 means disabling a driver. Try removing the line and it will work as well. You can simply write blacklist nouveau in a file clled blacklist.conf and it is parsed. However, an extra file method is better. +1 for an attempt to answer. – infoclogged Sep 20 '17 at 19:01

Not the answer you're looking for? Browse other questions tagged or ask your own question.