0

I've installed Kubuntu, Ubuntu, and Lubuntu successfully on other machines but I'm stuck and really not sure what the problem is, nor how to fix it. It just never gets past the where are you?/timezone step.

Hardware: Brand new Dell XPS 13 w/ Windows 10, 512GB SDD and 16GB RAM
Goal: Dual boot Windows 10 & Kubuntu 16.04 (or Ubuntu with option to replace gnome with plasma)

I followed Dell XPS 13 9360 Dualboot Windows 10 and Ubuntu 16.04 for the most part, I just didn't need to re-install Windows because it booted just fine after I switched from RAID to AHCI mode. I pulled the product key so I'm fine reinstalling windows if needed.

Here's what I did

  1. created recovery
  2. updated bios
  3. flashed Kubuntu 16.04 64 bit to 4GB SD card
  4. disabled secure boot in bios
  5. changed to ahci in bios
  6. enabled boot from usb and boot from sd reader in bios
  7. reboot into windows - no problems
  8. resized windows c: partition from 450GB to 200GB
  9. reboot into Kubuntu using SD card (UEFI mode)
  10. install Kubuntu using UI
  11. unchecked install updates and 3rd party
  12. chose "other" in disk setup
  13. created ext4 at mount "/" with all but 16GB of unallocated space (~200GB so plenty of room)
  14. created swap with remaining 16GB
  15. set boot record location to the top of the ssd (sd card was default)
  16. picked timezone, hit continue
  17. it's still spinning (I've left it to run by itself for over an hour)

I've re-tried steps 9-15 a number of times now trying different things. I tried with Ubuntu 16.04 standard and get stuck at same spot. I created ext4 and swap partitions in gparted before starting installation and get stuck at same spot.

I even tried installing Kubuntu to external usb hdd, copied entire partition to internal ssd, boot using livecd on sd card, installed boot-fix to install grub2 after the fact. Boot-fix throws an error saying it detected GPT and to create an unformatted partition and add a bios_grub flag. I tried that and re-ran boot-fix but it still gives the same error.

One more thing I pulled syslog in /var/log and I'm getting a lot of errors like this:
Sep 20 17:00:33 kubuntu ubiquity: find:
Sep 20 17:00:33 kubuntu ubiquity: â/target/boot/efi/EFI/dell/logs/\277?6|$\{n.dh?/!\344\a\027\260? ?.\003f/T??\+n?\353.z?gâ Sep 20 17:00:33 kubuntu ubiquity: : Input/output error
Sep 20 17:00:33 kubuntu ubiquity:
Sep 20 17:00:33 kubuntu kernel: [ 3485.758985] FAT-fs (nvme0n1p1): error, invalid access to FAT (entry 0x59d106ed)

partition 1 on the drive is named "EFI system partition" at mount point /target/boot/efi, label = ESP, and flags = "boot,esp", fs = fat32.

I'm thinking the GPT table is causing the problem but I'm not sure what to do about it. I'm willing to wipe the entire drive clean if I must, but I'd rather not. UEFI, secure boot, and GPT are all newer tech that I don't have any experience with so I'm used it just working out of the box without much difficulty.

update I had an issue with flashing the ISO to SD using rufus so I started using etcher instead. I was reading through https://help.ubuntu.com/community/UEFI to make sure I wasn't missing anything and I figured I should start all over again, including a fresh download of the ISO. I used rufus again and saw an option for partition scheme that I had not noticed before and that etcher didn't offer. I re-flashed the image using the "GFT partition scheme for UEFI" option. However, that results in a card I can't boot from.

  • did you disable quickstart in windows? quiickstart is really a hiibernate and locks partitions that windows is using, including the EFI partition. – ravery Sep 20 '17 at 17:40
  • I disabled "fast startup" under power options in Windows. is that what you are referring to? There is a hibernate option under shutdown settings that was enabled as well. I just removed that option but I don't know if that is related because I do a full power down not hibernate when I close windows and reboot into linux. – Todd Sep 20 '17 at 17:53
  • In addition to updating UEFI, many have had to update firmware on SSD especially if newer NVMe type. Some also needed boot option: Dell with NVMe needs AHCI & boot option nvme_load=YES dell.com/support/article/us/en/19/sln299303/… & askubuntu.com/questions/867488/… & askubuntu.com/questions/884991/… – oldfred Sep 20 '17 at 18:59
  • dell.com link says to add the nvme_load=YES if it isn't able to see the drive. it can see the drive without any problem and I already changed SATA to AHCI. I also already updated the firmware from Dell as per your second link which I used as my initial guide. – Todd Sep 20 '17 at 19:22
  • @todd -- fast startup is what I was referring to. it is actually a hibernate. – ravery Sep 20 '17 at 19:41

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.