0

The problem arises because I use SSL. The guides for no encryption work fine, such as Start Synergy (or any application) BEFORE logging in Ubuntu 16.04.2 LTS

I have created the file

    /etc/lightdm/lightdm.conf.d/50-ubuntu.conf

and added the following lines

    [SeatDefaults]
    greeter-setup-script=/usr/bin/synergyc --enable-crypto 192.168.x.x

In order to for the SSL encryption not to give error "failed to verify server certificate fingerprint", I have added the server's fingerprint to

    ~/.synergy/SSL/Fingerprints/TrustedServers.txt

If I run the command

    /usr/bin/synergyc --enable-crypto 192.168.x.x

after login it works fine. If I disable SSL on the server and remove the --enable-crypto from the 50-ubuntu.conf file, it works fine.

I suspect it is because the Fingerprint of the server is in my home directory, which is not accessible to the account running the stuff before I'm logged in, but I'm not sure how to fix it.

I tried adding the fingerprint to

    /home/root/.synergy/SSL/Fingerprints/TrustedServers.txt

(none of these folders existed before), but it didn't work.

Hope you can help me :)

0

The finerprint of the server needs to be added to

/root/.synergy/SSL/Fingerprints/TrustedServers.txt

As the home directory of the root user is not /home/root/ but /root, as per this question What is "~" (home directory) defined as for programs running before login using LightDM?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.