2

So I've been pulling my hair out over this for the last couple days now, I can't seem to find any solutions that work. I've fresh installed Ubuntu Gnome 16.04 on my system which has no other OS's running on it. Everything's fine aside from the fact that the default Nouveau display driver seems to be causing the UI to freeze sporadically every now and then. No problem right? Just install the proprietary drivers for my GPU and we should be golden? Well here's the thing, no matter how I try to get my GPU's drivers installed I always seem to hit some sort of issue. Here's what I've tried so far:

  1. Switch to the proprietary driver from within the 'Software & Updates' app in Ubuntu. For me the only option available is the 'NVIDIA binary driver - version 375.66 from nvidia-375 (proprietary, tested)'.

After selecting this driver it goes through the install process, asks me to 'configure secure boot' by entering a password, etc. This all seems to work fine initially until I reboot, but then before I see the login screen it seems to open a virtual terminal (usually accessed via alt+shift+F1), but then immediately boots me back to a black screen where it will flash this terminal for a split second every 4 seconds or so. I can access this terminal by using alt+shift+F1, and go on to use it as normal, but it will continually boot me back out to the black screen every few seconds. The only way I can solve this is to keep accessing the terminal each time it boots me out while I purge the nvidia drivers using sudo apt purge nvidia-*. After purging I'm then able to access the login screen and access my Ubuntu again as normal, besides having to reboot to presumably activate the Nouveau drivers again otherwise the resolution is all messed up and only one of my three monitors has anything displayed on it.

  1. Using the steps listed here I download the latest stable/certified driver for my GPU (which as of writing this is version 384.69). However on step 3 where it instructs me to run the driver using sudo sh, I reach an issue where the installer informs me that I need to disable the Nouveau driver in order to continue. I've tried everything from uninstalling Nouveau using 'sudo apt-get remove --purge xserver-xorg-video-nouveau` to blacklisting Nouveau using the steps listed here, by editing the 'nvidia-graphics-drivers.conf'.

Unfortunately no matter what I do to try and disable Nouveau the installer always informs me that the Nouveau driver is enabled and needs to be disabled in order to continue. What's funny is that I managed to install the driver using this method once before, but for the life of me I can't get it to work again.

  1. Finally, I've attempted to install the driver by installing the PPA. I run sudo add-apt-repository ppa:graphics-drivers/ppa, sudo apt update, and finally going back into the 'Software & Updates' app and select the 384.69 driver. However after going through the install process the same issue as described in my first method (1.) occurs.

I've also tried switching between gdm3 and lightdm with all 3 methods to no avail. I'm at a complete loss as to what to do. If anyone has any possible solutions I'd love to hear them, because right now I'm at the end of my tether.

If you require any further information just let me know and I'll be more than happy to provide it.

System info:

AMD FX-8350

Nvidia GeForce GT710 1gb

16gb RAM

Ubuntu Gnome 16.04 LTS

  • 2
    I have a feeling that secure boot is the issue – Android Dev Sep 20 '17 at 13:59
  • 1
    @Android Dev - That's the thing, I've tried disabling secure boot and the issue still persists? I can always try again if you wish, I'm once again running a completely fresh install of Ubuntu in preparation for any suggestions made here in any case... – Meta Sep 20 '17 at 14:10
  • With all your attempts, better check the /etc/modules.d blacklists for any leftovers (or go for a fresh install). – ubfan1 Sep 20 '17 at 15:13
  • @ubfan1 - As stated above I preemptively fresh installed anyway. The only things I've installed since are Chromium and Discord, other than that I've made no other changes save for general UI config. I've made no attempt to install any graphics drivers this time around, I'm waiting to see if anyone can offer any other solutions first. – Meta Sep 20 '17 at 16:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.