1

My laptop is an ASUS K555UB (i5 6200U, GeForce 940M), running dualboot Ubuntu 17.04 and Windows 10.

The speakers sound "hollow" and with weird bass on Ubuntu compared with Win10, but when using any external speaker/headphone, they sound pretty similar in both OS.

Also, ASUS provides an audio software for Windows (AudioWizard Screenshot). Without it, the sound became similar to the one on Ubuntu

Details on Ubuntu:

$ pacmd list-sinks | grep sample
      sample spec: s16le 2ch 44100Hz

$ head -n 1 /proc/asound/card*/codec#*
      ==> /proc/asound/card0/codec#0 <==
      Codec: Realtek ALC256

      ==> /proc/asound/card0/codec#2 <==
      Codec: Intel Skylake HDMI

$ aplay -l
      **** List of PLAYBACK Hardware Devices ****
      card 0: PCH [HDA Intel PCH], device 0: ALC256 Analog [ALC256 Analog]
        Subdevices: 1/1
        Subdevice #0: subdevice #0
      card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
        Subdevices: 1/1
        Subdevice #0: subdevice #0
      card 0: PCH [HDA Intel PCH], device 7: HDMI 1 [HDMI 1]
        Subdevices: 1/1
        Subdevice #0: subdevice #0
      card 0: PCH [HDA Intel PCH], device 8: HDMI 2 [HDMI 2]
        Subdevices: 1/1
        Subdevice #0: subdevice #0

In the driver page from ASUS, there isn't any software for Linux systems.

There is any similar software alternative or workaround for Ubuntu?

I tried to install pulseaudio EQ as suggested by Olimjon, but it was already installed and it doesn't appear in the launcher.

In terminal I got this info

$ pulseaudio
       E: [pulseaudio] pid.c: Daemon already running.
       E: [pulseaudio] main.c: pa_pid_file_create() failed.

Should I remove/purge current installation and reinstall? Or there is a bigger problem?

Thanks for any help

1

Yes, there is software called PulseAudio Equalizer.

PulseAudio Equalizer has an integrated 10-band equalizer system and provides an effective workaround for Audiowizard for Ubuntu. To install press Ctrl+Alt+T and type:

sudo add-apt-repository ppa:nilarimogard/webupd8
sudo apt-get update
sudo apt-get install pulseaudio-equalizer

I recommend you to select Headphones preset.

For more Info, check this.

6
  • It seems that it was already installed, but i'm getting errors I'll add them in an edit – Benjamin Sep 20 '17 at 13:27
  • Maybe, you just run pulseaudio-equalizer from terminal? – Olimjon Sep 20 '17 at 16:04
  • Tried that, but it isn't registered as a command – Benjamin Sep 20 '17 at 17:12
  • Well, in that case, do sudo apt-get purge pulseaudio-equalizer and install it again from repo that I gave, then run pulseaudio-equalizer-gtk – Olimjon Sep 21 '17 at 0:53
  • I suppose, this error occured because pulseaudio-equalizer is available on Zesty official repo, but the version is 1.1, in webupd8 repo it is 2.7. – Olimjon Sep 21 '17 at 0:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.