2

Issue

I can't access certain sites on Ubuntu 16.04 LTS.

Sites I can access: google.com, nba.com, youtube.com, and gmail.com. I was actually able to log into my gmail account with no issues.

Sites I can't access: ebay.com, bankofamerica.com, and askubuntu.com. (I'm asking this question via host machine)

Things I've tried

It seems several folks have come across internet issues after installing ubuntu.

This guy suggested changing the mtu in ifconfig. I tried this, but could not do the last step of making the settings permanent. For starters, there isn't an interfaces directory in the network directory. I have an interfaces file, which I tried adding "mtu 1492" and saving, but was denied (I tried to sudo echo "mtu 1492" >> interfaces.txt but that did not work either; denied permission). There is an interfaces.d directory, but nothing in there.

Some folks here suggested changing mtu as well, with one user saying that 1454 worked. I tried it. Didn't work. (I went as low as 1400) From this same link, another person suggested manually entering the ip address under the IPV4 Settings tab in the "Editing Wired Connection 1" dialog box. I entered the ip address, the netmask, and gateway, but could not save this info (the save button was blurred out)

This forum suggested updating the firmware by cloning a repo on git. Tried it, but could not get it to work (github is one of the sites that i can't access, so could not clone the repo)

This person suggested it's a browser issue, but I doubt it. The same issues exist when using Ubuntu's native browser (the one with a blue background and the compass)

This person suggested running sudo pppoeconf. I ran it, but nothing. it scanned device looking for pppoe access concentrator; response said access concentrator provided did not respond. maybe pppoe was hibernating

This lady did an update and upgrade and said it worked for her, so I tried it myself. It updated fine for me. No errors. "Reading package lists... Done". For the upgrade, it said 126 upgraded, 3 did not. Otherwise, the upgrading process looked similar to what I've experienced and seen in the past (this is probably the 10th+ time I've done a fresh install of ubuntu in virtualbox since 2013). I saw no errors during the upgrade. After update and upgrade, I restarted machine. Issue was not solved.

Here are my specs

Host OS: Windows 8

Guest OS (on virtualbox): Ubuntu 16.04 LTS (fresh install)

Virtual Box: v 5.1.28 (fresh install)

Network Adapter 1 (under Ubuntu Settings > Network): Attached to Bridged Adapter, Intel (R) Centrino (R) Wireless-N 2230

Browser: Firefox

IPV4 Settings Method: Automatic (DHCP); also tried Automatic (DHCP) addresses only, but nothing

IPV6 Settings Method: Automatic; tried addresses only and dhcp only, but nothing; automatic was the only setting that let me into sites like youtube and nba.com

NOTE:

It should be noted that with every suggestion I tried, I did it in two ways. First attempt, I did it, and tested internet. When I saw that it didn't work, I repeated the same steps, but before testing the internet, I restarted ubuntu, then tested internet. (as you can tell from this ridiculously lengthy post, i was quite thorough in my attempts)

Can anyone help? I came across internet issues in the past, but a little minor tweak here and there usually fixed it. This one is tough.

  • Use NAT instead of bridge. Most likely you can access only sites with IPV6. – Pilot6 Sep 19 '17 at 20:10
  • Are you using a router or you computer is connected directly to ISP? – Pilot6 Sep 19 '17 at 20:11
  • Could you try to update interfaces file with sudo nano /etc/network/interfaces and add the line mtu beside the correct interface? – ob2 Sep 19 '17 at 20:11
  • @Pilot6 Hi Pilot. Thank you so much. I feel embarrassed now. I didn't even think to change the freaking network adapter. Wow. I'm not sure if this post will be removed, but your answer helped me. (Thanks for the response olivierb2; I appreciate it) – user123456 Sep 19 '17 at 20:16
  • I don't think I have the rep to mark your answer as correct, Pilot6 – user123456 Sep 19 '17 at 20:16
2

It looks like you can access only sites with IPV6.

This means that your guest system doesn't have IPV4 access to the internet.

Most likely you are not using a router and your ISP doesn't allow more than one computer to connect using IPV4.

It can be solved by changing network settings from Bridge to NAT in VirtualBox.

  • thanks again :) (I tried to upvote this, but my rep is too low lol) – user123456 Sep 19 '17 at 20:22
  • side note: i hope mods keep this post up. i went through a process of elimination and cited sources, and with your help, pilot6, i was able to narrow it down to a network adapter issue. this could definitely be helpful to others i'm sure. – user123456 Sep 19 '17 at 20:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.