0

I'm trying to format a USB that is readonly. I've mistakenly removed the SecureAccess files and now the file system is readonly. I've tried some solutions like this:

Read only filesystem problem

But still no result. In proc/mounts file /dev/sdb is of type iso9660 ro.

Is there another solution I should try? Thanks.

Edited: After trying to format from disks I got the following error:

Error formatting disk
Error wiping device: Command-line `wipefs -a "/dev/sdb"' exited with non-zero exit status 1:
stdout: `5 bytes were erased at offset 0x8001 (iso9660)
they were: 43 44 30 30 31
'
stderr: `wipefs: error: /dev/sdb: probing initialization failed
' (udisks-error-quark, 0)
  • Follow the steps in this post ->askubuntu.com/questions/747702/… – Akhil Varma Sep 19 '17 at 20:06
  • How did you tried to format? Do you tried to create a partition on the USB drive? – ob2 Sep 19 '17 at 20:07
  • I edited my question and added the output from the format. – Iva Sep 19 '17 at 20:12
1
0

I found a solution. To format it:

sudo dd if=/dev/zero of=/dev/sd* 

in my case it was:

sudo dd if=/dev/zero of=/dev/sdb

It took some time. After that I format the USB using Disks.

Applied permissions:

sudo chmod 666 /dev/sd*

Mounted it using:

 sudo mount -o rw,users,umask=000  /dev/sd* /media/user/temp

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.