lspci | grep -E 'VGA|Display'

shows that it has found my graphics card which is in the supported list and works fine on windows:

01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Pitcairn PRO [Radeon HD 7850 / R7 265 / R9 270 1024SP]

dmesg doesn't show any errors.

glxinfo | grep OpenGL

shows that it is not using the GPU:

OpenGL renderer string: Gallium 0.4 on llvmpipe (LLVM 3.8, 256 bits)

Is there any way to force Ubuntu to use the GPU as I am currently unable to watch youtube and run phpstorm at the same time without considerable lag.

  • Well, in general, if you are using llvm your card is inadequate or unsupported. In general, gnome is more demanding of you graphics card so the problem may not be only with youtube. What driver are you using ? What drivers have you tried as an alternate ? Have you tried a desktop other than gnome ? kubuntu or lubuntu may be less demanding of your graphics card than gnome.
    – Panther
    Sep 19, 2017 at 15:55
  • I have been using the RadeonDriver which lists my card as fully supported. Haven't tried any other desktop or driver but am installing amdgpu-pro right now.
    – Rockroxx
    Sep 19, 2017 at 16:05
  • OK, good luck. It is the total load on your gpu and in my experience with a different card, llvm it is best to run KDE or XFCE (decent balance of features) rather then gnome/unity.
    – Panther
    Sep 19, 2017 at 16:54

1 Answer 1


The issue seems to be resolved after re-installing xorg.

glxinfo now shows

OpenGL renderer string: Gallium 0.4 on AMD PITCAIRN (DRM 3.16.0 / 4.4.0-96-generic, LLVM 4.0.0)

Compiz now isn't eating 35 to 50% of my cpu anymore.

  • 1
    Welcome to Ask Ubuntu! I recommend to edit this answer to expand it with specific details about how to do this. (See also How do I write a good answer? for general advice about what sorts of answers are considered most valuable on Ask Ubuntu.) Sep 20, 2017 at 8:42

Not the answer you're looking for? Browse other questions tagged or ask your own question.