0

I'm running Ubuntu 16.04 on my laptop, and it has an Intel graphics card. I realized my drivers were out of date, so I went to https://01.org/linuxgraphics/ and downloaded intel-graphics-update-tool_2.0.2_amd64.deb and installed it via dpkg. When I run the tool however, it works fine until it comes to the point where it installs the updates. It gives this error:

Error running transaction: 
GDBus.Error:org.debian.apt.TransactionFailed: error-dep-resolution-
failed: The following packages have unmet dependencies:

libgles1-mesa: Depends: libglapi-mesa (= 12.0.6-0ubuntu0.16.04.1) but 
17.0.7-0ubuntu0.16.04.1 is to be installed

I checked, and I do have the latest version of libglapi-mesa. Version 17.0.7-0ubuntu0.16.04.1

What do I do about this?

  • Did you follow the instructions about signatures? Please edit and post the results of sudo apt update. – user692175 Sep 19 '17 at 15:49
  • @MichaelBay no I didn't. What instructions? – Curtice Gough Sep 19 '17 at 15:50
  • The instructions in the downloads page: Signatures - Ubuntu* (01.org/linuxgraphics/downloads/…) – user692175 Sep 19 '17 at 15:51
  • @MichaelBay I just followed the instructions and added the GPG key, but I still get the same error when the update tool is run. – Curtice Gough Sep 19 '17 at 15:57
  • Check the answer. Please note it only corrects the error induced by the incorrect use of the Intel tool. It doesn't correct other software source errors you may have had previously. And once added (the keys) you don't need to run the tool again, just update the system. The tool is just a fancy GUI that, in the background, adds the PPA (- key) and runs sudo apt update / upgrade. That's ALL it does and generally you don't need it because all Intel provides are minor updates. If any relevant update is needed it will be added to the official Ubuntu repositories. – user692175 Sep 19 '17 at 16:08
1

The Intel® Graphics Update Tool adds the Intel's PPA. As mentioned here, in order to "trust" the Intel® Graphics Update Tool for Linux OS, you will need to add keys to Ubuntu's software package manager ("apt"). Ideally this should be done before running for the first time or upgrading from an earlier release. But can be done now and should work for the purpose if there are no other issues with your software sources.

In terminal please run the following commands:

wget --no-check-certificate https://download.01.org/gfx/RPM-GPG-KEY-ilg-4 -O - | \
sudo apt-key add -

Then the app itself is no longer needed. Do a full update and the new versions, if any, will be downloaded and installed:

sudo apt update
sudo apt full-upgrade
  • Thanks! That works great. Except for one thing. What does this mean? W: https://download.01.org/gfx/ubuntu/16.04/main/dists/xenial/InRelease: Signature by key 09D6EF97BFB38E916EF060E756A3DEF863961D39 uses weak digest algorithm (SHA1) – Curtice Gough Sep 19 '17 at 16:07
  • It means exactly what it says and it's not a big deal (it doesn't prevent the update) and nothing that can be "solved" from the users side. Some time ago, Debian/Ubuntu started strongly recommending the use of stronger algorithms but many third party repositories "didn't get the memo" (or did and ignored it). Only the maintainers (Intel in this case) can improve it. – user692175 Sep 19 '17 at 16:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.