1

I've just re-booted my ubuntu 16:04 box and now can't load any of my webpages. Seems the mysql hasn't started.

How can I de-bug this problem?

When I try to start it with the 'sudo service mysql start' command I get a red message, Failed to Start MySQL community server.

Annoyingly, it worked before the re-boot. Any ideas would be really appreciated. Thanks in advance.

  • Usually you should also see a hint where to find the error log files together with the message. Afaik should be in /var/log/mysql or something similar. Probably a corrupted config file which didn't get applied until the reboot. – derHugo Sep 19 '17 at 16:43
1

for check mysql status, open your terminal and type :

sudo systemctl status mysql.service

the log directory for error is located in /var/log/mysql/error.log, to show it you can use this command :

cat /var/log/mysql/error.log

hope this will help you

  • Thanks Deki. I am running the service on a virtual box and it looks like I "filled it up" so, this is a temporary solution. I will ensure I don't install anything else, just leave it running, and stop "fixing it" the old adage of don't fix it unless it's broken comes to mind. When I ran the error log you gave me, I thought that the screen was never going to stop scrolling ;-) – Vincent Gledhill Sep 19 '17 at 19:41
  • you're wellcome... the screen never going to stop scrolling?? I think there are Huge error on your log.... so it is make the screen scrolling, but it will be stop scrolling when all error was printed in your terminal.. – Deki Akbar Sep 19 '17 at 20:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.