2

So I was trying to install VLC through the command line, as I did with other distros. After installation I found that I can only access my linux partition/s, but not the other partitions/drives(when I choose to open a directory my other partitions aren't even there!). The same problem is with SMPlyaer.

A little digging showed me that I've might've installed the snap version, but that isn't the case either.

I tried installing from the software center, but to no avail...

There's a snap version on the software center, and another version that's not obviously a snap version. I tried both of them...

I installed and used Ubuntu a long time ago, it was my intro into Linux, ans I was perfectly able to install and play with VLC without any problem. I didn't have this type of problem on Mint or Manjaro either...

So what's going on here?

Here' what I have when I try to open a file on SMPlayer, it's the same case when I'm using VLC:

"Choose a file tab on SMPlayer"

As you can see I only have my root partition there for selection, not any other partitions(Windows NTFS partitions...)

  • it's probable that the other partitions you hoped to see were not yet mounted. – guiverc Sep 18 '17 at 10:24
  • are the other partitions mounted? – ravery Sep 18 '17 at 10:24
3

In the screenshot, only your root partition is shown. This is normal, as a lot of the applications present this exact screen when asked to select files as well.

Now, this might solve your problem:

  1. Make sure you have the partitions mounted through Nautilus or other applications you would like to use.

  2. Enter the folder /media/sakib. In there it should show the list of partition you mounted.

In the following screenshot you can see that my partitions are mounted in /run/media/cynplytholowazy/, and once you enter the folder you will see the list of partitions you have mounted. (It's probably in your /media/sakib folder)

Folder list view

  • That worked!! My question sounds so trivial and stupid now! I should've tried what you just said- on Manjaro KDE this same thing happed, but there I had my partitions listed on the left, but when I mounted them from VLC, they showed up in /media/sakib; that just didn't click in my head here in this case! Thanks a lot! – Apollonius Sep 18 '17 at 12:31
  • No problem, many people just didn't realize that it can be done through checking /media/(user) as well. – Cynplytholowazy Sep 18 '17 at 12:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.