I am having hard time connecting to the Internet using my 4G modem Huawei E5372 on my Desktop PC on Ubuntu via USB,

I have the following error

Error mounting /dev/sr1 at /media/userpc/MobileWiFi:

 Command-line `mount -t "iso9660" -o "uhelper=udisks2,nodev,nosuid,uid=1000,gid=1000,iocharset=utf8,mode=0400,dmode=0500" "/dev/sr1" 
"/media/userpc/MobileWiFi"' exited with non-zero exit status 32: mount: /dev/sr1 is already mounted or /media/userpc/MobileWiFi busy
enter code here

Edit: requested dmesg output.

  • Please edit the output of lsusb into your post. Thank you for helping us help you! – Elder Geek Sep 17 '17 at 21:42

Open up the terminal type "lsusb" and check wheter your device is being detected as an network card or not. USB modem can be identified as an Network card,cd rom and an usb storage.So your system will pick one i.e cd rom as its mounted first.

This is actually done by usb mod switch so instead of switching to cd rom,your should be switched as an network card.

Now I suppose you dont have the required drivers so instead I will provide two of them.Try one of them and they verify wheter it worked or not.

This is a github link to Huwaei drivers link so you can use "git clone https://github.com/siddht4/Huwaei_linux_drivers" to clone/download to your system.

So now start installing the drivers.

Assuming you have chosen A.

Note : Make sure that you have make,build-essential,gcc,g++ already in your system.

Step 1: Navigate to the sub folder i.e "Linux", can be done in terminal by "cd Linux"

Step 2: Then you will find "install" file, which you have to run as root.This file will install Huwaei drivers for Linux.

Do do so,open up terminal in the current directory or continue in the terminal opened at step 1, in terminal type "sudo ./install", this will install the Huwaei drivers. This will also use NDIS module to support your modem.

Step 3: Reboot so that the installed new modules are loaded in your system. Now connect your USB modem and verify wheter it works or not.

  • Worked like a charm – Ralexrdz Feb 22 '20 at 21:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.