0

Apparently I have the nosuid option enabled on my Ubuntu /dev/sda4 EXT4 FileSystem partition:

mount 

sysfs on /sys type sysfs (rw,nosuid,nodev,noexec,relatime)
proc on /proc type proc (rw,nosuid,nodev,noexec,relatime)
udev on /dev type devtmpfs   (rw,nosuid,relatime,size=6093284k,nr_inodes=1523321,mode=755)
devpts on /dev/pts type devpts   (rw,nosuid,noexec,relatime,gid=5,mode=620,ptmxmode=000)
tmpfs on /run type tmpfs  (rw,nosuid,noexec,relatime,size=1223224k,mode=755)
/dev/sda4 on / type ext4 (rw,relatime,errors=remount-ro,data=ordered)
securityfs on /sys/kernel/security type securityfs  (rw,nosuid,nodev,noexec,relatime)
tmpfs on /dev/shm type tmpfs (rw,nosuid,nodev)
tmpfs on /run/lock type tmpfs (rw,nosuid,nodev,noexec,relatime,size=5120k)
tmpfs on /sys/fs/cgroup type tmpfs (ro,nosuid,nodev,noexec,mode=755)
cgroup on /sys/fs/cgroup/systemd type cgroup  (rw,nosuid,nodev,noexec,relatime,xattr,release_agent=/lib/systemd/systemd-  cgroups-agent,name=systemd)
pstore on /sys/fs/pstore type pstore (rw,nosuid,nodev,noexec,relatime)
efivarfs on /sys/firmware/efi/efivars type efivarfs (rw,nosuid,nodev,noexec,relatime)
cgroup on /sys/fs/cgroup/cpu,cpuacct type cgroup (rw,nosuid,nodev,noexec,relatime,cpu,cpuacct)
cgroup on /sys/fs/cgroup/devices type cgroup (rw,nosuid,nodev,noexec,relatime,devices)
cgroup on /sys/fs/cgroup/memory type cgroup (rw,nosuid,nodev,noexec,relatime,memory)
cgroup on /sys/fs/cgroup/net_cls,net_prio type cgroup (rw,nosuid,nodev,noexec,relatime,net_cls,net_prio)
cgroup on /sys/fs/cgroup/pids type cgroup (rw,nosuid,nodev,noexec,relatime,pids)
cgroup on /sys/fs/cgroup/blkio type cgroup (rw,nosuid,nodev,noexec,relatime,blkio)
cgroup on /sys/fs/cgroup/hugetlb type cgroup (rw,nosuid,nodev,noexec,relatime,hugetlb)
cgroup on /sys/fs/cgroup/freezer type cgroup (rw,nosuid,nodev,noexec,relatime,freezer)
cgroup on /sys/fs/cgroup/cpuset type cgroup (rw,nosuid,nodev,noexec,relatime,cpuset)
cgroup on /sys/fs/cgroup/perf_event type cgroup (rw,nosuid,nodev,noexec,relatime,perf_event)
systemd-1 on /proc/sys/fs/binfmt_misc type autofs (rw,relatime,fd=30,pgrp=1,timeout=0,minproto=5,maxproto=5,direct,pipe_ino=700)

I looked around a bit and I know nosuid It's enabled due to security reasons, but is it possible to turn it off?

  • which partition and why ? What are you trying to accomplish ? – Panther Sep 17 '17 at 16:18
  • I don't see nosuid on sda4 - just rw,relatime,errors=remount-ro,data=ordered – steeldriver Sep 17 '17 at 16:23
1

you should not change these settings especially for mounted partitons at / aka root. Any wrong tinkering with the fstab file may make your system unable to boot.

nosuid means Block the operation of suid, and sgid bits. So if instead you set it to false i.e not having it in the fstab file, then during boot the volume wont mount properly and your system may enter in shell mode.

Example : /proc volume has the task of allocating and storing a cache like database for all the running process. It gets every permission i.e 777 and has root privileges. If by chance someone managed to unount it by setting other permission then your kernel would panic and your system would get crashed.

  • Ok then I wont do touch it. – IDK Sep 17 '17 at 18:40
  • and your /dev/sda4 happens to be your root partition – SIDDHARTH Sep 17 '17 at 19:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.