This question already has an answer here:

The same question has been asked before, but the answers that I found did not work for me, so I'm asking a new question.

I'm the main user and only sudoer on this computer, and everything works for me.

The second user account on this machine for no reason that I can think of, no longer displays the launcher sidebar or top bar, neither does CTRL + ALT + T work. Icons are normally displayed on the desktop (in most other related questions like this the desktop is blank).

So I've found and tried so far:

  • rebooting
  • sudo service lightdm restart
  • unity --replace
  • unity --reset-icons
  • apt-get install --reinstall ubuntu-desktop
  • apt-get install --reinstall lightdm
  • remove files under /home/USER/.config/compiz-1/compizconfig
  • starting ccsm from tty to enable unity plugin

unity reset commands return "no display variable set" and "compiz core couldn't open display 0".

When I try to launch unity from tty with DISPLAY=:0 unity I get the following:

Invalid MIT-MAGIC-COOKIE-1 keycompiz (core) - Fatal: couldn't open display :0

Which sounds like it could be relevant?

How to restore desktop panels?

marked as duplicate by karel, Yaron, David Foerster, Eric Carvalho, user364819 Sep 18 '17 at 21:46

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • try the answer, it's worked for me askubuntu.com/questions/760825/… – Abdalrhman Rafik Sep 17 '17 at 14:15
  • Thanks karel, unfortunately much of what is there is outdated/deprecated, and I found no solution. I'll update the question in a second. – kurja Sep 18 '17 at 14:54
  • I you create a new user account do you have the same issue that you are reporting with "the second user account"? – Elder Geek Sep 19 '17 at 22:52
  • @ElderGeek Nope, when I make a new account it works as expected. – kurja Sep 20 '17 at 19:15
  • That sounds like an issue with that particular users profile then. You may find this useful. – Elder Geek Sep 20 '17 at 20:19

the source : Unity doesn't load, no Launcher, no Dash appears

You just need to turn the Unity plugin back on. The problem is this is a pain in the bottom because you've now got no graphical method to do this. So:

  1. Try to open a terminal with Ctrl+Alt+T.
    This may not work but you can try right clicking on the desktop and selecting "Open terminal here." Otherwise, you may need to change to a "hard" terminal by pressing Ctrl+Alt+F1 and log in.

  2. Install compizconfig-settings-manager by running

    sudo apt-get install compizconfig-settings-manager
  3. Then run it with this:

    DISPLAY=:0 ccsm &

    The first part tells the terminal which display you want it to load on (otherwise it won't have a clue).

  4. If you switched to a TTY in step 1, switch back to the graphical server by pressing Ctrl+Alt+F7 (or Ctrl+Alt+F8 sometimes).
    There there should be a CompizConfig Settings Manager waiting for you.

  5. Find the Unity plugin. Enable it. You will be asked "Ubuntu Unity Plugin requires the plugin OpenGL. Enable Ubuntu Unity Plugin / Enable OpenGL"

  6. Everything should spring into life but if it doesn't, you might have to restart. You can do that by going back to the terminal and running sudo reboot.

  • I get Gtkwarning:could not open display, and AttributeError: 'NoneType' object has no attribute 'get_default_screen' – kurja Sep 17 '17 at 18:45
  • I can open ccsm from tty when logged into my own account though. But not when I'm logged in to the problem account. – kurja Sep 17 '17 at 18:52
  • look at this thread : ubuntuforums.org/showthread.php?t=1866462 – Abdalrhman Rafik Sep 17 '17 at 19:19
  • Please delete one of your answers or merge them. Only under very rare circumstances should you create two separate answers to the same question. – David Foerster Sep 18 '17 at 11:21
  • I was able to start ccsm after export DISPLAY=:0.0 but enabling the unity plugin did nothing for me. – kurja Sep 18 '17 at 19:18

Not the answer you're looking for? Browse other questions tagged or ask your own question.