0

I am trying to install Ubuntu alongside Windows 10 on a Lenevo machine. Installing Ubuntu from a Live USB fails and I get a popup with the error "Unable to install GRUB in /dev/sda". Checking the system log shows this error,

grub-install: error: cannot open '/boot/efi/EFI/ubuntu/shimx64.efi': Not a directory.
error: Running 'grub-install -force "/dev/sda"' failed.

I have secure boot, fast boot and hibernation mode off. I have also tried installing Grub from the command line and get the same error. I haven't been able to find any information on solving the specific "Not a directory" error so I'm kind of at a loss.

  • you need to install grub-efi – ravery Sep 16 '17 at 17:09
  • I have tried installing grub-efi from the command line but get the same error "grub-install: error: cannot open '/boot/efi/EFI/ubuntu/shimx64.efi': Not a directory." – Alan J Sep 16 '17 at 17:29
  • is the EFI partition mounted? – ravery Sep 16 '17 at 17:30
  • Yes, I followed this answer: askubuntu.com/a/778165/737567 for mounting the EFI partition and installing grub. – Alan J Sep 16 '17 at 17:39
  • 1
    Thank you, for some reason /boot/efi/EFI/ubuntu was a file instead of a folder. Deleting the file and running the installation again fixed the problem. – Alan J Sep 17 '17 at 1:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.